Can't get machine to move the right direction when cutting

Hey all. I just setup lightbutn to run on a generic 3018 CNC with the 5.5 watt blue laser. It’s running GRBL 1.1

Here are my current settings. Can someone please help me fix this?

$$
$0=10
$1=25
$2=0
$3=2
$4=0
$5=0
$6=0
$10=0
$11=0.010
$12=0.002
$13=0
$20=0
$21=0
$22=0
$23=0
$24=25.000
$25=500.000
$26=250
$27=1.000
$30=8000
$31=0
$32=1
$100=800.000
$101=800.000
$102=800.000
$110=1600.000
$111=1600.000
$112=1600.000
$120=5000.000
$121=5000.000
$122=5000.000
$130=290.000
$131=170.000
$132=40.000
ok

The settings don’t help much without more context. What do you mean by “the right direction”? What direction is it moving now, compared to what you’re asking it to do?

When I start a cut, even though I have my origin set bottom left hand corner, and a small image centered in the workspace, it immediately tries to jog the wrong way. It doesn’t have limit switches so it it just bumps against the machine edge until I stop it.

It like my axis are reversed in the software or something? I should mention this only appears to happen with the Y axis.

“It doesn’t have limit switches” - that’s going to be the whole problem right there. Neither LightBurn or the controller will have any idea where it is until you tell it. You’d need to jog manually to the front left and zero the laser (using G92 X0 Y0 in the console) or just run using ‘Current Position’ mode as the Start From value, and setting an appropriate job origin.

Read here: https://github.com/LightBurnSoftware/Documentation/blob/master/CoordinatesOrigin.md#coordinates-and-job-origin

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.