Changed (Mac) computers and Air assist no longer working

Firstly, I had my upgraded air assist working on my previous Macbook. So I loaded my previous machine settings on the new Mac and checked to make sure that “Enable air assist output” was " true" and I wrote it back to the controller. I checked the connection to make sure the wires had not come loose from my solenoid. I searched over the threads and one recommendation is to send to the controller then start. I tried the alt (option for mac)+shift+s and that didn’t even move the laser, so I went to the laser itself and hit start and it did not turn on.

  1. Anyone have any suggestions?
  2. Any idea why option+shift+S won’t work?

Also, the compressor is on and is charged

And there is no 24V at the connection for the air assist when running a program.

Did you do this because it wasn’t working with the new Mac? Reason I ask is Machine Settings are actually stored at the controller so should not have required rewriting. In that case, I’m wondering if you accidentally overwrote the wrong settings.

You can explore backups in File->Load Prefs Backup.

1 Like

No I think I just loaded it thinking it would be required. I’m pretty sure it was the correct settings regardless. But would any of this matter? The only option that needs to be checked for it to pulse is machine settings > vendor settings > Enable air assist output = true…and it was…

Does Air Assist continue to work on the old computer?

1 Like

Good point, didn’t even think to check that… I will try that when I get home again. Back at my day job. Thank you for the suggestion.

OK so in my opinion this is good news… somewhat. When I go back to my previous Mac, it works as intended. However, I’m not certain what I can do at this point. I’ve tried changing out the Machine settings again, same result.

You’re really trying to force the issue with that one…

Try this.

  1. From working installation:
    File->Export Prefs and save to a file
  2. Transfer exported file to new computer
  3. From new installation:
    File->Import Prefs and select the file
  4. Retest

Sorry, I just thought that was what you were suggesting. Perhaps I need to brush up on my lingo. I always lose things in translation. Preferences does not relate to machine settings then. I actually did look at the Preferences Backup as you suggested, just thought that would all be contained in the file I was referencing. I’ll try to better break down what I’m being told. Again, my apologies.

Haha. Nothing to apologize for. I just thought it was funny that you were going to make that work one way or another.

So I didn’t quite follow. Are you saying you did try using the Prefs backup and it didn’t work? And that what you were calling Machine Settings was actually the Prefs backup? Or something else?

So I just tried loading the prefs as you suggested and that did not work unfortunately.

What I meant there was prior to the last post I looked at the File->Load Prefs Backup as you had suggested and just decided (wrongly) that it was all related (Prefs - Machine settings) so a backup was going to be no different.

So you loaded prefs from a backup on the new computer and that’s not working?

Are you running the same project? Is it possible you haven’t enabled “Air Assist” in the Cut setting?


Oh dear lord…I need to take the walk of shame. That’s a rookie move. Thanks for sticking with me. It’s just always been there and I never think to mess with it.
Thank you!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.