Changing focus height on layer problem, Z or U axis confusion maybe?

Hi. I have a OMTech AF2028 60W. I’m trying to get it so that I can defocus the cut for a score line on one layer. I went to device settings and enabled all 3 settings under Z-axis control.

I set my one layer to -10 mm. When I run the cut, the machine pauses before that layer as if it’s moving the bed, but it isn’t actually moving. I can control the z position of the bed from the ‘MOVE’ menu.

I was reading a few threads on here that seemed to suggest that the problem might be that my controller calls the z-axis the U axis instead? A couple of those threads hinted at a possible future fix, but I never did see if there actually was a fix and if so how to do it. Any suggestions? Or is there something else I’m missing to be able to control the bed from lightburn during a cut?

Thanks!
Leigh

What three settings?

Does you Z axis home when you power it up?

A quick check of how the hardware is put together will tell you that part of it. You can ‘look’ into the electronics cabinet and see where the wires for the Z axes driver and where it’s plugged into at the controllers connector, ‘axis u’ or ‘axis z’.

It appears to be a DSP controller, here is mine… a Ruida 6442

Red is the U axes and the Green is Z axis motor driver control output.

You could move it to the other axes by moving the ‘plug’ that would move the hardware to the controllers other axes. You would still have to figure out if it’s something configured in soft/firmware and limit switches if they exist.

Good luck

:smiley_cat: