Changing settings on imported files do not save to gcode

I’m a brand new user and I have a Creality 10w laser. I use an HP Elitebook with Win 10 OS and I’ve just downloaded Lightburn so I’m sure I have the latest version.
I downloaded a simple file and imported it into Lighburn and wanted to change the power on the border lines to 100%. That works, but when I save the file as gcode to put on the SD card to insert it into the laser, the power settings always default back to the original values (20%). Am I doing something wrong when I try to save it?

How are you making those changes?
Post pictures with your steps also post your Project file (xxxxx.lbrn2).
image

I use the import button, select the file and it loads up just fine. I adjust the power settings here;

I use the Save As and select gcode. It saves just fine. When I open that file, the settings have reverted to original from the source file.
NewUni.lbrn2 (23.8 KB)

original file

qommpj4o.dxf (167.3 KB)

and here is the gcode file that I get when I save gcode from the file menu

NewUni.gc (16.8 KB)

The g-code you posted shows 150mm/min:

image

Perhaps it’s picking up some layer defaults you’ve set when you re-import it making you think that the new settings haven’t been saved?

Both the GCode file and .lbrn2 file you’ve shared are showing the correct values from the screenshot above when I open them.

I suspect what’s happening when you “open” the file again is that you are actually Importing — when you Import a .lbrn2 project, you get the graphics only, not cut settings. 20% power is just the universal default in LightBurn that all layers revert back to, if you have Load default layer settings on new or restart enabled, and have not set your own custom defaults.

Try going to FileOpen and re-opening the NewUni.lbrn2 file — you should see the correct settings, as I did.

2 Likes

Thank you for the help

1 Like