Chinese blue and grey laser . Power issue, x axis not working properly

I hope someone can help me please?

Had an issue where the laser was tripping out the electrics when getting plugged in. Did all of the usual checks. Then when it was working I was getting a red light on my x axis driver, the head stuttered back and forth beforehand and just died.
The nema 17 motor was really hot. So i have replaced this and now again have the same problem. It worked then it seemed like the motor was overheating and dying.

I looked at each stepper driver and the steps were different to each motor. They were both the same apart from SW3 which was on on my Y axis and off on the X axis. Could this be my issue?
I have turned it to on now.
I am a complete novice when it comes to electrics.
I am running it on uk mains.

Looks like the new motor will not work now. So will have to order another.
Power to both stepper drivers is 25v on each.

The Nema 17 Iam using is a 1.7a 2 phase/ 4 wire with 1.8 deg and 48 mm body.

Hopefully someone ca assist me as i have orders backed up.

Thanks in advance


None of your photos completely loaded. Only drop one at a time and wait for it to upload.

I assume you mean the circuit breaker. When you have an issue like this, it would be nice to know what you fixed to be able to plug it in. It’s possibly related.

What are the ‘usual’ checks your performed?

Not know what kind of driver module this is, sw3 doesn’t mean much… On my driver it part of the supplied current. I would think the same motors would use the same current.

Find the problem cause and quit replacing motors, that’s a temporary band aid covering up the problem.

Something isn’t right somewhere if you need to replace the motors. I’d look elsewhere such as the driver being configured correctly or has a hardware issue. Motors are also pretty tough.

I’d suggest a good look at the power supplies as a start.

Good luck


Checked and replaced all fuses on chiller, laser, extractor and air pump.

Hopefully picture of the stepper driver now loads.

This had SW3 in the off position, yet the other stepper for the other motor was set to on.

The power no longer cuts out or trips the electrics.

After changing the motor it worked fine for 30 minutes before getting hot to touch and then failing and the stepper driver led going from green to red.
Are these settings correct, now that i have mirrored the other drivers settings.

Any help would be appreciated.

Change of the switch allowed you to plug it in?

I would think they should be the same for the same motor. They are on mine.

Might want to find the manual for this driver and find out what a red light is trying to tell you.


Change of all fuses allowed no more electric tripping.

I will check the led but red says alarm and will light up for the following reasons .
When over voltage, low voltage, or even over current, the red LED lights up.

Is this a new machine that could be miswired from the start?
Possible stepper probs:

  1. the 4 wires are 2x “A” and 2x “B” windings. A and B and +/- are equivalent in every way, but you must pick a letter for the winding, not cross them. That is, a winding on the motor can’t be connected from A+ to B-.
  2. A wire is broken somehow. Anything that keeps one winding from running will mean the motor just shakes badly.
  3. your motor drive is blown. Get a new one. This is the likely case

The machine has been running for 3 years without any issues. Until recently. But was concerned that the x axis stepper driver was not the same as the Y axis driver, with both the same motors.

Have ordered a new motor but wanted to be sure that the SW values were set correctly, as i have no knowledge on this subject just wondered if this was the issue or a red herring. As these dont just flick positions on there own.

Or can you get a pre wired harness for these that just needs wiring to the motor?

Danny are you talking about the driver unit rather than the motor? I have a new motor coming, but can order a new stepper driver unit if that is what you are suggesting?

Yep the motor drive. Steppers almost never “go bad”. I had a direct-drive NEMA17 that had the bearing fail, but nothing else. On the other hand, I’ve had a couple of drive failures over the years