Chinese Laser with Ruida RDC6442S-B (EC) Controller - Stopped Working


I’ve recently been tasked with finding information to fix a Chinese Laser Engraving Machine.

It has a Ruida RDC6442S-B (EC) Controller.

The exact Laser can be found at the following link (The Laser I’m working on wasn’t bought from this site though).–11325640.html

Essentially, the company that I do work for purchased this machine from a third party a few months ago. The only instructions we got from the Supplier was a USB with an arbitrary driver and a half chinese video showing how to install the software (which was quite unhelpful).

When they first got the machine, it worked perfectly. We use Lightburn. The machine has two unlabelled USB ports on the side. We first sent jobs to the Engraver by plugging in a USB drive into one of the ports. The Engraver would detect the drive and the job would commence.

However, the USB port on the machine broke off after a month. The side of the Engraver was opened and the USB drive was connected directly to the Ruida Controller via an extension cable and it worked.

However, we directly connected the Ruida Controller to the PC via the PC-USB port. With this, we could send jobs directly to the Engraver from Lightburn/RDWorks. This worked for 2 months.

Then, the Laser tube stopped working for some reason. A new laser was purchased and installed. The machine worked for 1 week.

Fast Forward to today, nothing is working. Connecting the Ruida Controller directly to the PC does nothing. Connecting drives to the U-Drive Port on the controller does nothing. I’ve connected a ethernet cable into the Ruida Ethernet Port, configured a static IP on the device for the network. The Ruida Controller comes up on the network, however Lightburn nor RDworks detect the laser at the IP. I want to reiterate the if you ping the IP or scan the network, the Ruida’s IP is detected.

I am at my wits end with this machine and need some assistance.

I’ve included the following links with pictures which should assist.

You need to stop abusing this equipment. I don’t know how many times yall stomped the usb cable out of the port till it quit working, but I’m sure it took serveral. Then you didn’t have sense enough to attach a replacement, you attached directly to the controller and now you have jerked the cable out of it till you have ruined it.

Did you even connect a cooling system or did you just run dry till it fried.?

supposing the control has power it should be displaying some information, does the machine home? doies the amplifier have power? does the amplifier power up?

IN the worst case scenario you shoiuld be able to replace the controller and get back running. That would only be about $300 usd. I would screw a usb extension to the machine and get plenty of extras so the monkeys swinging on the computer usb would keep you shut down.

Thanks for the reply Maccass. You could’ve simply offered help and asked questions. You didn’t have to be so abusive and throw so many insults.

  1. There is a cooling system connected to the machine.
  2. The machine homes.
  3. The amplifier powers up.

You also didn’t have to insult people by calling them monkeys.

The last option would be to replace the controller. Is there anything else I could try in the meantime?

Can you access the files in the machine from the controller keypad/display?

To use Udrive port you will have to use usb stick less than 2Gbyte in size. format it to fat 32 or fat16. not extended fat32. then store files only on the root and use file names 8 char or less.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.