Choose M3 or M4 per layer


I have a DIY CO2 laser running on GRBL-ESP32, which is terrific BTW.

I have issues when cutting with the M4 command as corners sometimes don’t cut due to the variable power using M4. I found a post from around 12 months ago which Oz answered but is now closed:-

F LightBurnOz

Jan 19

There isn’t a good way to fix this with GRBL unfortunately. The only real option is to use the GRBL-M3 profile in LightBurn (constant power mode) for cutting. We have an update coming that will allow you to choose M3 (constant) or M4 (variable) power per layer, which would help, but ultimately standard GRBL doesn’t work well for glass tube CO2 lasers.

Did this feature make it to a release?



Forcing constant mode is in the next release. Likely to be released this week.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.