Circles cutting as ovals

I have been using my rotary and trying to switch back to regular cutting. No issues with homing origin. When trying to cut a circle, it is coming out as an oval. Its like it is struck in rotary mode.

I have ensured that my rotary is disabled, have also deleted all prefs and reloaded machine a few times now.
Reset the machine upwards of 20 times now. No luck

Spinning my wheels. Have used the rotary before and not run in to this.

Only way I can get mine to go back to normal is to disable the rotary, shut off the machine, unplug the rotary and plug the y axis back in and restart. That works every time for me.

hmm - did these steps and its not recognizing.
I just redid your exact steps as well and still busting out ovals.

Weird. Only other thing I’ve had do that is when I had my machine bed dimensions off. That was very early on though and I was off on my mm to inches conversion. :slight_smile:

Check your $100 and $101 settings. They “should” be the same.

You can get them by putting $$ in the console window or going to machine settings under edit.

Ahhh - the machine I use is controlled with a Ruida - no console or GRBL control. On to the next idea.

Oh, ya, next is the right idea.
I tried.

1 Like

Is it possible that the steps/rev are still being seen as whatever the rotary was/is set up for?
Do you have a backup of your machine settings that you can reload into LightBurn and push back into the Ruida controller?

1 Like

I feel like this is exactly what my issue is… it is acting like the rotary is still engaged. It definitely is disabled. I have reconnected the rotary and gone through the steps to disengage. It def is no longer enabled in the Rotary set up tab.
I don’t have a back up file. I have deleted all my prefs and reinstalled the machine about 7 times now. My understanding as that this would rest back to default but still cutting ovals.

You’re my Hero.
Your response prompted me to open the vendor settings and yep - the X and Y step length did not match. Updated the Y setting to match my X and I am back to slaying my circles over here.
Thank you!!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.