Click 'Start' but nothing happens

Hello! I am having trouble running files from Lightburn. I am using a BOSS Laser 1420 with a Ruida controller, and I am operating Lightburn 0.9.24 on macOS Big Sur, connected to the laser via USB cable. I am able to ‘Frame’ my file, I can move the laser head, but when I click ‘Start,’ nothing happens. Then, if I try to do another action, like ‘Frame’ again, it states “There was a problem sending data to the laser. The Machine may be busy or paused.” I can fire the machine and run files manually via the machine controller, but I cannot ‘Start’ or ‘Send’ files via Lightburn. I have checked that the laser is connected, and it is. I managed to run a couple files earlier today when I first started, but now, nothing.

you’ll probably want to mention what version of LightBurn you are running. v0.9.24 would be the preferred if I’ve read the posts correctly. It’s a beta with some MacOS comms patches along with other things.

Not anymore :wink:, we have released 0.9.24 to the public as announced here: LightBurn 0.9.24 released - Comms issues for MacOS / Ruida resolved, a – LightBurn Software

And, I believe @Eric_Ryberg mentions they are using 9.24 on Big Sur with Ruida.

1 Like

Thank you. This is the first report 9.24 is not working as expected. All other reports so far, have confirmed resolution to the communication issues, so thank you for providing this information. Investigating now. Which Ruida controller model and firmware are you using in this Boss. Are you using a USB hub or extension cable, by chance? If so, this might be intermittent or dropped data due to less than ideal hardware connection.

The maximum in-spec length for USB cables is 5 meters (16.4 feet) without an extension. If you need to go longer you can purchase an amplified cable which is basically a single-port USB hub that repeats the signal. Also, double-check that all plugs are seated on known good ports. :wink:

Anything major difference between the files you successfully ran vs the failed ones you can think of? I know I am grasping a bit, as I am trying to reproduce this behavior here.

@LightBurn, tagging for review.


Thank you for your reply! I uninstalled and reinstalled Lightburn, and now everything seems to be working fine. I will report any further issues, if I experience any.

For the sake of answering your questions, I am using a direct USB cable from the machine to the computer. This cable was provided by Boss Laser and I have not added an extension.

The files were identical. I was creating Test Tiles for engraving settings on different materials. I was simply cutting a test tile, swapping the material, then running the file again, but at some point Lightburn could not fully communicate with the controller.

Anyway, like I said, it is running great now. Thanks again!


We like hearing you got sorted. Please report back if you see this again or any other issues we can help you resolve. :slight_smile:

Having the same issue with my windows 10 PC running ver 9.24 Everything was fine until i installed 9.24 now no comm with controller? but it runs RD Works fine? need help fast!!!

You can always roll back to an older version for the fastest fix. :slight_smile:

Which Ruida controller model number and firmware, when you can? And you say, “comms”. Can you please be a bit clearer as to what you have tried?

Thanks Rick I tried that nothing worked? I ended up finding an old config file I had stored on an old thumb drive that fixed it! haven’t had time to compare and see the difference? But will report back when I do!

Please do. Provide as much detail as you can. I have not seen this reported before. Exact steps to reproduce would be ideal, but anything is helpful. Thanks. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.