Comgo Z1 not connecting Lightburn

So I’ve got a brand new Comgo Z1. Firmware is up-to-date. Using Lightburn v. 13 and 12 both give this issue. When Z1 is turned on and plugged in, it recognised the port “cu.usbserial-1410”. It says ‘Ready’ in the Lazer-window. But, it keeps “Waiting for connection…”

I’ve spend 12 hours now, followed every video or manual you could possibly find, screened through every forum, but STILL I don’t have any solution to this problem.

At first it stays on “waiting for connection…”. But when I tap on ‘devices’ with a double tap it wants to reconnect and will show “Port failed to open - already in use?”. From here on, I can’t get the status to be ‘ready’ anymore. I need to close and re-open Lightburn, then it’s back to ‘Ready’.
I’ve done everything I can to find any issue with the USB on this Macbook, but there doesn’t seem to be any issue.

So why does it stay on “waiting for connection…” even tough it seems to be connected, since it says “ready”. ??

When I type ‘$$’ it will return ‘Go’ to me, but repeatingly until an endless list of the word ‘Go’ in the Console display.

Device settings for the Z1 are set on S-value max 1000, Baud rate 921.600 and Buffered.

I’ve tried 115.200 as well as Synchronous as well as combinations. Via official Comgrow channels (video and manuals) it sometimes says we should select 115.200 and other times 912.600. While I assume only 1 of these is correct.

I sincerely hope someone can help me. Since I’m lost in this issue, no solution so far and not the way I was hoping to start my experience with Comgrow + Lightburn.

Try enabling “Enable DTR signal” in Edit->Device Settings. Start with 115,200 for baud but try 912,600 if that doesn’t work.

Make sure that the port is indeed selected in Laser window when you do this.

Thank you kindly for the respons.

I’ve tried Enable DTR signal from the beginning, was one of the first ‘solutions’ I found in forums. But doesn’t make s difference.

Same with the Baud rate and I’m sure I select the right port, since only 1 shows up after attaching the usb. My MacBook has (only) 2 ports, have been trying both many times.

Can you confirm that your machine is setup as a GRBL device?

  1. Push Devices button in Laser window
  2. Then click once on the name of your laser. This should show you details at the bottom of the window
  3. Take a screenshot and post here please

Yes, it’s set up as GRBL, done manually. I’ve also tried Lightburn 14 just now, but same issue.

Screenshot:

Can you click on the name of your laser once, then retake the screenshot? Some information is missing that I want to confirm.

Also, is your Mac Intel or Apple chip based?

Ah you’re right, here again with the info;

It’s a Mac Intel chipset.

Okay. Note that there are multiple GRBL variants that all use the same GRBL icon so wanted to confirm that you were indeed on GRBL.

I don’t see anything obvious that would be preventing connection. I thought that if you had an Apple chip based Mac that it could be a security issue.

Do you have any other serial application that you could use to try to connect to the laser?

Good idea. I’ve installed and tried Laserweb. I select USB, Port and Baud rate. It connects for about 3-5 seconds and then disconnects with the message “no supported firmware detected”.

My guess is, that even tough firmware upgrading is as easy as; put ‘firmware’ file into laser motherboard via tf-card, while disconnected and off-power, plug power back and turn on for +20 sec, turn off, and remove tf-card. Then the new firmware should be installed, but I have no way at all to actually check if it installed the new firmware or not.
If it did succesfully install the firmware, it should have connected and tell me the firmware is there.
The Comgo Z1 support is however almost non-existence, nobody there is responding to it.

I think there are 2 possible issues:

  1. bad firmware - firmware isn’t behaving as it should
  2. bad serial driver - it’s possible that the driver that’s on your computer isn’t working correctly. This is fairly common on Mac with either incompatible drivers being shipped or competing drivers being loaded.

Do you have a separate computer that you could use to test? That could eliminate the second issue relatively easily. If not, can you confirm which driver is used for the serial communication. Check under System Report->Hardware->USB and then find your specific USB-Serial device.

I’ve tried 3 different firmwares, different versions, so assuming they install correctly, at least one of them should be okay I assume. But indeed maybe 1 is faulty. I got respons from comgrow, they will send me the driver via e-mail, I will try that one as soon as I receive it. Will let you know what happens.

Unfortunelately I don’t have a second computer, and don’t know anyone around where I live. (just moved country). But I will try to find another computer to test with.

I’ve checked the usb serial drivers; see print-screen;

Also checked via terminal;
Schermafbeelding 2023-04-21 om 18.18.43

By now I’m pretty sure the drivers are okay. So hopefully the Z1 firmware that Comgrow will send me will make all the difference.

The fact that there are two ports for the same driver indicates a problem.

Notice both the usbserial-1410 and wchusbserial1410.

Can you try connecting to wchusbserial1410 to see if that works?

Looks like this is using WCH34x usb chipset. If the above doesn’t work then take a look through this post. It will give you some clues as to how to check if there are multiple drivers installed and how to resolve. The thing is Monterey should have an Apple provided driver. I assume that’s the one providing the “usbserial-1410”. I suspect the custom driver is providing the “wchusbserial1410”.
GitHub - adrianmihalko/ch340g-ch34g-ch34x-mac-os-x-driver: CH340G CH34G CH34X Mac OS X driver

1 Like

The wchusbserial1410 actually just exists since a few hours ago, has not been there yesterday when I had the problem.
Before it was only the usbserial-1410, which is indeed the default driver from Apple. Which I checked many times and was sure it was installed properly.
But after more manuals and reading I got the recommendation to install the wchusbserial1410, indeed a custom, to see if that would solve it. It did solve it for someone else, so worth the shot. Unfortunately it didn’t solve it for me. So i’ll be removing it again.

You may want to try relocating the Apple provided drivers so that they don’t interfere with the WCH driver. That is likely to work correctly.

I’ve removed both drivers again. Did a clean new install off the CH340x.

But, can’t connect the Z1 yet. I’ve noticed the Z1 never blinked green, which according to other forums should blink now and then. I wonder if this indicates something more is wrong with the controller-board, than maybe just the firmware.

The Comgrow support haven’t been able to solve it either yet.

Isn’t there a way to force a firmware onto the GRBL? Instead of using the tf-card with ‘firmware’ on it. Back in the day (long time ago) I used to program a lot and usually connected a controller board and forced something to it.

I looked at the firmware update method and it’s not very assuring. Are the LED lights supposed to indicate a successful flash?

Can you confirm that the serial device is wchusbserial? Have you rebooted your computer since making the driver change? There have been reports of that being required at times.

Also, have you tried various combinations of “Enable DTR Signal” and baud rate?

Alternative approach, could you run Windows in a VM or run Linux from a USB drive to test the laser that way?

Not sure, it seems after the firmware upgrade the green light flashes one time but no where it is mentioned, and I assume they don’t actually upgrade it when making the instruction video.

I did ask congrow about this but no respons yet, hopefully Monday.

The wchusbserial is now removed, only the original usbserial-1410 is installed. (Some reported installing wchusbserial solved their connection issue, so had to try).

I’ve rebooted a couple of times to be sure.

Also tried combinations of Baud rate and toggle the DTR Signal. Often restarted in between chances.

I was wondering if Emulation Windows could help, but now you’ve mentioned it I better try it out. Hopefully I’ll get to that tomorrow. Either Windows or Linux, one more recommended than the other?

Both seem to work equally well from what I’ve seen. If you try Linux I’d recommend trying with Ubuntu 2020.04. With Linux for sure you won’t need to install a driver.

change of plans. Comgrow is now going to send me a new board. They agree on the board being broken, since there are no green lights blinking at all. I was just about to install Ubuntu, but for now I rather wait for the new board.

So after many many hours it seems it’s just a broken board. But, I’m very thank full for all your help! Great to have a dedicated support behind Lightburn. Looking forward to start using Lightburn ones it’s up and running.