Comgo Z1 wont connect

Hey all… Been using Lightburn with my Xtool D1 a while and love it! Just added a Comgro Z1 and cannot get Lightburn to connect with it. Laser status says “Ready” but console says Waiting for connection.
I did install the driver. Added the Comgro as a GRBL laser. Still nothing. It seems to work fine in LaserGRBL which is weird.

Somehow it did work with lightburn for a few minutes however everything I did worked backasswards. If I hit the arrow to move laser module forward it went backwards. When I loaded a file I had burned with the Xtool it was upside down on the screen with the Comgro.

Any help would be greatly appreciated!

If it worked for a few minutes then basic setup must be there.

Can you make sure you’ve selected the correct port for the Comgro in Laser window?

There was another user on here who could only connect to LightBurn but not LaserGRBL on his Z1. Curious what that’s about.

Check Device Settings and make sure baud rate matches what you had in LaserGRBL. Try toggling “Enable DTR” to see if that makes a difference.

Just hooked up a different laptop and now the comgo wont even work on lasergrbl with it… UGH!

I’m just starting to tinker with a Comgrow Z1.

The baud rate setting is pretty high - I got it to connect but i’m still getting exhaust set up.

1 Like

Following, I am Having same problem with a comgo z1, works with laser grbl but wont connect with lightburn…