Communication issues?

In the above picture (if i put them in correct order) you see a message telling me that there was a communication error and in the next photo, you will see that the laser was started and actually running after getting the error.

Anyone know what is going on? To my knowledge, lightburn doesnt log in console with a ruida like it does a grbl. So i am unsure of what is happening.
This issue began after the latest update. Essentially the laser will be running fine and a loud thunk happens. When i look at the work piece, the laser is sitting still. Hitting start/pause will make the head jiggle, but nothing else. I tried hitting the e stop and to no avail. The ruida asks if i want to continue from power outage and if i accept, it just says “calculating, please wait”

Are you setup to run ethernet or USB on your controller?

Light bridge?! Whatever that is. Guessing ethernet, via the lightbridge.

Is this repeatable and happen in the same place?

I run the Lightburn bridge also and it’s wifi but the Pi is connected to the laser via the Ethernet port.

I understood that Lightburn sends the file to the Ruida and then starts it, but I don’t know.

If it’s repeatable, it might be wise to let support know about and see if it’s some anomaly that is causing the issue, I’m sure they’d like to know.

@adammhaile might have a thought… I think he’s responsible for the bridge… :face_with_spiral_eyes:


The issue is happening in various spots. Also, yes, the light bridge is on wifi and then through the ethernet. I might actually be having a communication issue now that i think about it. I moved a pc and in the process, it changed the dynamics of my home wifi location, which is now further away. I put the pc in my work shop and it is running on wifi as well. Because the distance was as far as it is (20’ or so with some walls in the way) i hooked up my wifi entender. My thought is, the light bridge, which used to connect directly to the router is probably still trying to connect to the router and not the extender.

That would be a simple fix


Im not that computer savvy. Is it just goikg through the setup and selecting the extender instead? I often get an error trying to go through the browser setup

Yeah - sounds like you are having intermittent connectivity to the Bridge. Is the extender the same WiFi SSID (network name) as the normal access point?
You might just have to reboot the Bridge.

1 Like

Everything you just said is way over my head lol. I will have to take a look and see what i can find. Im considering getting some cat6 wire and putting a hub in to take the unreliability of wifi out of the equation

The Lightburn Bridge has a software layer in it to handle the UDP of the Ruida and smooth out some of it’s issues…

I’d suggest you stick with the bridge, just get some signal to it… I’ve run mine with a pc to Ruida direct connect cable also… like the bridge better.


At the very least, i can run a wire from the router to the extension, as it has a hard wire port on it and that will give me a fighting chance to have a decent wifi in the my workshop

This picture is a terribly sketched‐birds eye view of my house. In the lower right corner, you will see where the laser and the lightbridge is located. High middle, you will see the original location of the router (nighthawk a10 i think). In the low middle-right, you will see where the extenders location. The router has now been moved into a more open location to the top left area (livingroom). When i originally set everything up, i set it up over a laptop. Since then i have migrated to a desktop pc that stays in the shop (bottom right)
Issue i am having is, i cant quite wrap my mind around what i need to do. I imagine that when the lightbridge setup initially happened, i set it up to go the home1 which is my router name (havent changed it yet, i know… lame) the entender is an ext2700 netgear extender (ext1). The desktop is connected to ext1, but i think the lightbridge is trying to connect to home1, which is technically about 5 feet further away than before.
The routers new location to the shop where everything is located is roughly 20-25 feet with some walls in the way. I live in an old farmhouse that does not have a lot of wire routing access points, hence the extender.
My thought is that lightbridge is trying to access home1 to then talk to ext1 and then the desktop. Does that sound like a logical explanation?
Short of snaking wires (unsire if i even can) how can i get lightbridge to acknowledge ext1? Every time i try to access it just says “took to long to connect” and sometimes that error is instant

Never mind. Somehow i figured out that my pi had a faulty power wire and was intermittently working

Great, that’s the best kind of fix :crazy_face:

I’m sure @adammhaile well be OK with that also…


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.