Communication with controller failed after latest version

Just upgraded to vers 0.9.13, machine is a Boss LS1420 with ruida controller. It will no longer read machine settings or communicate. Any ideas

Nothing in the communication code for Ruida has changed. What operating system do you use, and how are you connected to the controller? (USB, Ethernet, WiFi?)

Had same problem when I updated. Restarted computer and is working fine at moment. Have a Thunder Nova 35 using Windows 10 operating system on computer.

OS: Windows 10
Connection: USB
getting a code 43 usb error

That is not a LightBurn error - that sounds like an issue with the controller connection or the cable. I think that’s a coincidence.

Came back next day and still having problem with not communicating with laser. Backed up to 9.11 and still have issue. Went through laser setup and still no communication.

This does not tell us much beyond you having trouble. Maybe some details about what you have tried, how you have tried to connect, and the detailed results of this work?

You are jumping in on an existing conversation and not offering much for us to work with. We do want to help. We need you to help us, so we can help you.

When I send a file from Lightburn, it tells me that it has failed, laser may be busy or paused. I would try to move head from computer and nothing moves, even after shutting down and restarting laser. I go to Devices to see if Lightburn see laser, it tells me nothing is connected. I use USB to connect. I did update software back to 9.13. Starting to wonder if cable issue. Don’t have one that long to try at moment. Have only had laser for a month. Does this help?

That’s more information, so that’s good. A few things to try:

  • Power the laser first, then run LightBurn. You should see “Found RDCxxxx” in the status bar on the bottom of the main window.

  • Check your windows device manager to see if there’s anything in there that says a USB device is unrecognized.

  • Unplug the USB, and plug it back in - do you hear the ‘Ding!’ that says Windows knows something was connected? If not, probably a bad cable or connection

  • Are you plugged in to the ‘PC USB’ port on the laser, or the ‘UDisk’ port? (should be PC-USB)

I changed USB ports on computer and it seems to recognize it at this time. I will check the other 2 items next time it doesn’t seem to communicate. Laser is connected by an extra long printer cable that came with it so picking wrong port to connect to laser isn’t possible

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.