Computer will not communicate with laser

I have been using lightburn successfully for a long time using an ethernet connection. I recently changed my network router and now my computer cannot communicate with the laser. When I diagnose the connection its fine but I am getting a popup message about an IP address conflict. I am not sure why this is happening or where to look and resolve the conflict. I use windows 10 if that is helpful info. Can anyone help?

TIA

Sounds like you need to change the address it is using. Try using something like 192.168.0.244 as the address both in the controller and in LightBurn. The error you are receiving is saying that something else on the network is using the same IP address as your laser

The laser itself specifies its own IP address, which is sometimes a problem on home networks, as they dynamically assign IP addresses. You need to pick an address that’s “out of the way” and not likely to be chosen by the router, or there may be a way to tell the router itself not to use the address the laser is using. That would be specific to that router though.

Well I understand that pretty much but I’ve always manually designated the IP address for the laser as 192.168.1.100 and never had a problem. The only thing that changed recently whas I installed a new router and now this IP address won’t work. So I’m asking what do I to remove the IP conflict? I mean how can I find out what its conflicting with? What IP adress would be “out of the way”???

Your router administration interface might have a list of connected devices with their IP Addresses, otherwise install Advanced IP Scanner to get a list of what’s on your network. There you’ll see what IP’s are already taken.

Thanks everyone. I will give it another go :slight_smile:

192.168.1.100 could very well be the first address assigned by your router (some start there). If that’s the case, using 192.168.1.150 or 192.168.1.200 should be fine (the last number can go up to 254).

Like Oz said, many home routers start their dynamic IP addresses at 100. I would suggest setting the static address on the laser to a lower, rather than a higher, address to avoid IP conflicts. 192.168.1.20 for example.

On my router the dynamic address range is 100-254. This leaves 1-99 for static addresses like servers, IOT devices, and other things like my laser controller.

If you know how to access the management webpage of the router it is easy to check the DHCP settings for your router.

Stilll no luck. So I downloaded the advanced IP scanner, I see the following devices
IMG_1195 3 devivices, little guy (computer), the router and my phone. I also logged into my router and see the same 3 devices,
None of these look like there should be a conflict. I’ve tried entering all sorts of static IP addresses, above 100, below 100 and none work. I’ve tried resolving the conflict by going into the CMD prompt, flushing the DNS, releasing, renewing and resestablishing the IP addresses. I did notice after going through the CMD prompt exercise that my ethernet connection says duplicate after the IP address.could that be the problem?! if so how do I clear that? I also pinged the IP address and received a essage that the host was unreachable (i.e. my computer) now i’ve gotten to a point where I don’tknow if I’m coming or going. If any of you were in this situation what trouble shooting steps would you take? This is driving me crazy. I have jobs to do .BTW, I have the eithernet hooked up to my computer, not directly to the router.
TIA for any and all advice

On a housekeeping note, cell phone camera pictures of screens really bother my eyes.

Actual screenshots are highly preferred.

I’ve written a set of steps that might help, though it does sound like you’re doing this already:

1 Like

. So I open the CMD prompt, typed in ipconfig, under Ethernet I get
autoconfiguration IPv4 adress: 169.254.139.10
subnet mask: 255.255.255.0
default gateway:192.168.1.1

so I should enter something like 169.254.139.90 into the Ruida controller and lightburn? Do I also need manually assigned that number under the IPv4 properties under the ethernet network adapter settings? or should that be left as “automatically assign”?

Hooray. it worked!!! for both RD works and Light burn. Thank you so much! I guess I was misled by having always used that one IP address. another learning experience. Too bad it took hours to resolve. :sweat:

So you have the PC wired directly to the laser controller? If so that is why ifconfig showed 169.254.139.10. What happens if you reconnect the laser and the PC to the router?

You’re very welcome. It was a good push for me to write that up for the FAQ too. :slight_smile:

2 Likes

My laser is my garage workshop. The router is in the house.:blush:

1 Like

sorry about that. next time

1 Like

And has (almost) proven AutoMDIX works with Ruida controllers :slight_smile:

1 Like