Connection keeps dropping

network connection keeps dropping. Start the day by turning on the laser… connects right away. can send the file with no problem. Can resend the file , can send multiple files with no problem. after I run a job and try to send a file , file transfer failed. the machine maybe busy or paused. it shows disconnected and I cannot reconnect. Restart Laser, restart lightburn, right click device . nothing works…

ethernet connected through router
Windows 10/64 on Dell desktop
ruida rdc6445g(ec)
Lightburn 9.24

Thank you for reporting this. We are tracking an issue with this release, but have not had this exact thing reported.

At this point, I suggest you drop back to version 9.19 or 9.20 and try again. You can find these in our Older Version (< click that) repository. Please update with the results and again, thank you for providing this report. We are working to resolve. :slight_smile:

steps to revert back to older version.

The link I provided contains information. Visit that link, download the correct 9.20 version for your OS and you should be ready to go.

“All versions of LightBurn are available in our version archive, here: Releases · LightBurnSoftware/deployment · GitHub

Newbie at this. How do I revert back to a later edition? Will I lose my activation key? Steps to do this would be welcomed. Thanks!

No, you will not. You simply visit this link, which is the appropriate version for your computer [], download and install as you normally would. All your settings should be preserved. When you’ve completed the download, you should see the file in your “Downloads” folder. On Windows, you can just double-click the downloaded file to start the installation process.

Please update us as you progress, we are here to help sort this with you. :slight_smile:

Update : downloaded 9.19 install all went well.
connected right to the laser. sent several jobs all went well.
let the setup set for an hour … tried to send another job, shows disconnected. Cannot get it to reconnect.
restarted everything no luck. I changed address connection on both to another address , that connected right away. sent another job to the laser. worked fine. when that job completed, tried another job and its shows disconnected. will not connect again. went back to the other address, still will not connect.

We have not had reports of any LightBurn issues with 9.19 over Ethernet with this controller, so let’s check a few things.

For our clarity, how are you sending the job, by using the ‘Start’ button, or hitting ‘Send’, naming the file and running from the controller?

  • Does the controller have a lot of files stored on it? We have seen the Ruida act up when reaching its capacity. Clear files you do not need to ensure room for the transfer. In cases where the controller is close to full, they can be somewhat unstable.

  • Do you get these same results when testing from RDWorks? This would help isolate the issue being something in Software.

  • Make sure that the network cable is known to be good, well seated in the sockets at either end, and not running next to anything like a compressor motor or A/C fan.

  • On some setups, there is a short extension cable in the machine that connects the controller inside to a plug on the case, worth checking. Rare, but we have seen reports of those failing. If yours has a similar configuration, you could try opening the side panel to expose the main controller box inside (the white, smooth plastic box with lots of wires going in). On one end you’ll see PC-USB, UDisk, and Ethernet ports labeled - try plugging directly into the Ethernet port there, and if that works that could be the problem.

Let’s start with this, and update as you can. :slight_smile:

  1. I cleared all the file from the controller
  2. RDWorks is not installed
  3. change network cables
  4. short network cable - I went straight to the controller.
  5. tried anther PC on my network - same results.

Noted : if I shut down the laser for half hour , then start it back up it connects.
the ruida controller is using V.15.01.19

This would indicate something happening on the hardware side. This is one of the checks I was suggestion by trying RDWorks. If you get the same results from another software, that would point to something other than software. :slight_smile:

rdworks will not connect by ethernet or usb…

I now have a long enough usb cable. rd works did not connect .
went back to lightburn and tried usb connection and it worked.

This is good news, yet this…

RDWorks is the factory supplied software for Ruida control systems. If you are not able to connect and control the laser using this software, I might suggest it is time to reach back to your supplier for additional troubleshooting procedures.

I thank you for your help…
good day

Sorry I’m late to the party, right click Device button to recover/ reconnect USB?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.