Couldn't Start homing

Hi there,

I am new to lightburn.
I am using trial version of lightburn, having issue with homing with GRBL1.1h. I would love to buy licence once sort out this problem.
I have tried turn on $21 =1 hard limit switch, this function works perfectly fine.
But tried with the setting as per attached parameters, won’t start homing cycle, showing alarm 9.

Is there anything i have missed ?

ALARM:9 means it failed because it couldn’t find the limit switches. When you trigger the homing cycle, does it move toward the limit switches?

Read here for the GRBL config settings involved with homing, and how they work:

Hi, thank you for your reply. Nothing happened when click on home button. But as I mentioned when turn on hard switch, machine will stop when hit the limit switch but for homing why couldn’t find the switch. Can’t figure it out.

when i have tried with $5=1 as using normally open switch, it shows alarm 8. Tried different value for $27 upto 12 but nothing happen

$23 controls the direction the head moves for homing. When you start the homing cycle, is it moving toward the switches? This setting is a combination of these values:

1 : flip the X direction for homing
2 : flip the Y direction for homing
4 : flip the Z direction for homing

So, setting it to 3 (1 + 2) would flip both X and Y, but not Z. Setting it to 5 (4 + 1) would flip X and Z, and so on. If the controller is not moving the motors in the correct direction, they’ll never find the switches. It’s also possible that your step lengths aren’t correct - If the axis is not moving far enough per step, it may be giving up too early.

I have tried with all different value of $23 but nothing happened. Is there any setting for $24 which helps homing ? Thanks for your reply

When you say “nothing happened” do you get any messages in the console, any movement at all, etc? I can’t imagine a situation where nothing happens - the controller will either attempt to home and fail, giving an error, or it will tell you that homing is incorrectly configured, also giving an error.

It showing Alarm 8. I can hear humming noise on both x and y stepper motors.

That is quite a bit different than “nothing happens”. :slight_smile:

From the GRBL error list:
“ALARM:8” : _(“Homing fail. Cycle failed to clear limit switch when pulling off. Try increasing pull-off setting or check wiring.”)

1 Like

I am sure there is no wiring issue as hard limit switch working perfect. I have tried with pull off setting up to 12 but same situation.

Is this a machine you made yourself or purchased from somewhere? There are a handful of other things that could affect the operation of this - for example, if the step size was configured incorrectly, the machine could think it was moving farther than it actually is, or if the steppers were wired incorrectly, they might not be moving when they should be.

Hi, I have made this machine, used to with laser grbl software and did lots of engraving and cutting in past. I would like to switch over to lightburn as have nice features. Also just recently I have bought the limit switch, so I just trying to setup auto homing. In past I have also done calibration, steps calculation.


I have used the parameters as in attached picture. After i pressed home button and the quickly press the z limit switch couple of time, then auto homing works fine. I can’t figure it out the problem ? i also attached the picture of grbl controller board

Hi Oz,

Been waiting for reply. Just tried to edit config.h today to disable z switch and now auto homing working perfectly fine now.

Thank for you support.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.