Current position centered but job origin is not

Total noob here, but for some reason when I have origin as the middle its actually off a bit. Any idea what I’m doing wrong here? Looking at my image I would think the green square would be the middle of the box but its not and I can’t seem to move it. I feel like my last engraving went well but this one I’m struggling to get centered. Thank you for reading through this!

Job origin will be affected by all objects in workspace with your current settings. There’s likely another object on your workspace that’s affecting the location of job origin.

As @berainlb said, If however you want to negate any other objects in the workspace, select the ‘use selection origin’ in the laser palette

Gosh is there any way to move the green square to be the same as the grey square. Thats all I need to do.

  • I dont want or like absolute coordinates; as you can see I have built this in the middle of the screen, its hard to center in this mode. My machine has mm on the frame but its not accurate at all…

  • I tried to use current position with the laser centered perfectly over the object, but since the green square is off when I do a “frame” it goes off the object. I’m sure I could just manually jog the laser to be off center but this does not ensure a good print and will require me to hit “frame” at least multiple times to make sure I have it centered all while its technically not in the software.

  • User origin sounds most likely to be able to be used in this case but I cant seem to move the green square to the actual middle to match the grey square above.

What is the best to fix this? Really would like the green square to match with the grey square that way what I see on the screen is what I get in real life. Just seems odd to have to trick the software into doing this.

I’m not sure I see that option?

I have User Origin but cannot change anything. Clicking set origin and clear origin don’t do anything.

Doesn’t what I suggested work for you ?

Enable ‘use selection origin’, then whatever object within your workspace that is selected will be correct

Apologies, for this to work you must have ‘cut selected graphics’ enabled as well

Did you review my previous post? You likely have another object that’s affecting the job origin because all objects are considered when determining relative job placement.

You can use the technique offered by @Mooseuk as well but note that it’s a fundamentally different approach. That’s not changing the underlying scenario but simply stating, “only use the selected items in consideration for origin” which is a perfectly valid approach but just different than the base scenario.

1 Like

I was able to find the hidden object but I believe the behavior of the software should be different.

  • If an object is hidden it will not be printed so therefore why would it move the center?

Thank you for the help on this!

Glad that worked.

There are many times where you have non hidden items that you do want used. Additionally there could be cases where you temporarily hide the item because you’re doing multiple passes.

There are other methods of working around this if you don’t want this behavior such as using “Cut selected graphics” with “Use selection origin”.

If you don’t see it on the screen how do you find it?

This will depend on why it’s not visible. If it’s not visible because “Show” is off in Cut layer that would be more apparent. Tool layers are often also used for various functions and may not be set to on at all times. Using Select All also reveals selections not otherwise visible. Using Window->Frame Selection also will frame all available shapes. If it frames an area with no apparent shapes that implies that something is not visible and can be found by doing a box selection near that area.

In this particular case the green job origin being off center from visible shapes implies that there’s another shape playing a factor but not visible.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.