Current position starts from machine home

When selecting start from current position in lightburn, the laser starts the job from the machine absolute origin and not the lasers current position.

I have a Ruida 6445 controller and running the latest version of lightburn. I’m sending the job from lightburn to the controller and starting it from there.

I’ve seen “Current Position” not work on Thunder machines (not using a 6445, but using custom firmware). Two things to try:

  • Click ‘Devices’, then double click your laser, and change the connection to Packet/USB instead of Serial/USB

  • Try using ‘Send’ instead of ‘Start’

Do either of those work?

I’m connected by network so can’t test USB modes sorry.

I did some testing:

  • If I move the head to a position and press start in lightburn, it will run from current laser position.
  • I then press send in lightburn and load the file on the controller. Then move the laser position. When pressing start on the controller, the laser returns to the position where it was when lightburn started the job previously.

I’ve also noticed that after restarting the machine, it will home, and then return to the last point lightburn stated a job at.

Hi Hanna,

Did you manage to resolve this? I have the same issue, doesn’t matter what the Start from Position in LightBurn is or the origin in Device settings the laser will start from either the home position or somewhere near home. I have found that if I set origin on the controller then the machine will start in the right place but that surly cannot be the answer. Would be good to know if you resolved this and if so how. If not then hopefully my response will spark addition debate :slight_smile:

Hi John,
I havn’t resolved this. I’ve been using user origin and the origin button on the controller, or pressing start from lightburn (rather than send).

I’ve heard of others with the same issue. Have you tried running a simple test job from RDWorks? If it happens there too it’s a good indicator that the issue in the controller. If it doesn’t, that would suggest a LightBurn bug.

I’ve tested with RDWorks and it exhibits the same behavior as Lightburn as described in post 3&4.

The the issue is the hardware itself, and there’s not likely anything I can do to fix that.