Cut is not the same as the preview


(Greg) #1

I’m new to lightburn and testing the trial period.
I’m having a few issues but the important one is the cut/engrave is not as I designed it on the screen.


Hopefully the picture link works. It shows the screen and the object as it’s being cut.
The dalek was engraved first with no box surround. The tardis was engraved after with the box done last. I must admit that I cancelled on 90% but I couldn’t see the dalek box being completed.

(Rick James) #2

Sorry, but these pictures are blurry and not very helpful. Please try again using screen capture for all but the results image, and include a third picture showing the ‘Preview’ window.

Note: I have updated your profile to allow you to post more pictures in a single post.


(Greg) #4

I have made a new lightburn project from yesterday.

I am assuming that how it is designed in this picture is a ‘preview’ of the final cut/engrave -2 separate squares, 2 images for testing

The cut after finishing - Final cut layout

Dimension of the cut is fine but the layout is incorrect - correct size

Also on a side not the laser will not return to the start position (when finished) which i have set a origin. When the cut is finished and ‘go to origin’ is pressed it will end up some where near the original position - Issue with origin.
Would you like this put in a new post once this one is complete?


(Oz) #5

To me, that looks like your machine is losing steps when moving between cuts. Can you copy / paste the settings from GRBL when you type $$ in the console window?

The speeds you show for the scan and the cut are relatively slow, but if the acceleration or idle speed are set too high, your steppers could be skipping steps when traversing between the cuts.

A relatively simple way to test this is to run a small grid of evenly spaced squares, like this:
image

If you save the GCode, you can paste it into an online gcode plotting tool like https://nraynaud.github.io/webgcode/ and then compare the plotted results with what you get from your machine. If the results of someone else’s tool parsing the generated GCode look like what you see in the edit window and in the preview, then the issue is with the machine itself, or the controller settings.


(Greg) #6

$$
$0=25
$1=25
$2=0
$3=0
$4=0
$5=0
$6=0
$10=1
$11=0.010
$12=0.002
$13=0
$20=0
$21=0
$22=0
$23=0
$24=25.000
$25=500.000
$26=250
$27=1.000
$30=265
$31=1
$32=1
$100=800.000
$101=800.000
$102=250.000
$110=3000.000
$111=3000.000
$112=1500.000
$120=150.000
$121=150.000
$122=10.000
$130=500.000
$131=200.000
$132=200.000

Test 2 with a pattern square
https://photos.app.goo.gl/ymgwCoyTXo13V9yU6

engraved test 2 a pattern square https://photos.app.goo.gl/4PomtymY9twcbNeDA

gcode saved from lightburn to web based program https://photos.app.goo.gl/25PqSRBHpP23iRAG7

Many thanks for your time.


(Greg) #7

I have halved the X/Y acc to 75. This appears to have improved the engraving

https://photos.app.goo.gl/h4hDN2Pu6qE8LZwz8

Im re running the dalek test as posted first to see how that goes. The acceleration change could also sort out the origin issue I was having.


(Greg) #8

Unfortunately the dalek test first shown cuts/engraves the same. The g-code is shown correct from lightburn on the web based program


(Oz) #9

It’s quite likely that you need to increase the current on your motor drivers. 75mm/sec^2 is not fast for acceleration, so either your motors are very weak, or the current isn’t high enough to give you the torque you need to move your gantry.

Your profile says “Homemade diode grbl arduino”. I would look for mechanical issues - loose belts, pinions, or set screws, binding on the rails or bearings, as well as looking at how strong your motors are. Are they easily moved when the controller is powered up? If so, that’s not ideal.

I would also set $1 to 255 - That leaves the motors engaged at all times, instead of turning them off after a moment. That all by itself can cause missed steps and problems.

$30 should be either 255 or 1000, and make sure the “S value Max” setting in the Device Settings in LightBurn is set to the same value. $31 should be 0, not 1.

And finally, your steps per mm counts are quite high. Do you have high gearing, or just really high micro-stepping? If you’re running an Arduino, having a high microstep setting makes the controller do more work for very little gain - It’s worth lowering that if it’s not a mechanical limit.


(system) closed #10

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.