Cut Settings Editor Bug - Multiple Windows Opened

Ver 1.1.01, I keep getting 3 blank Cut Settings windows open that I can’t close.
I can dbl click layers, and open the actual populated Cut Settings, but can’t close these blank ones. Seem to appear after closing RDP, and re-opening again.

What is RDP? Are you referring to remote desktop platform?

If so, can you explain the steps and what you are doing? Is the LightBurn computer the client or server for the RDP session?

Yes, just RDP from one Win 10 desktop to another.
LB is the remote machine I do all my graphics work / design on and has LB installed.
I RDP into that desktop from the Laptop next to laser. LB is connected to laser via IP.

I have not tried LB through RDP so not familiar with any specific nuances there. Can you confirm the blank windows appear on the actual machine LB is running on, and not just on the client RDP side? And you are remote controlling the entire desktop, correct?

Your response is prompting all sorts of questions for me as it seems somewhat peculiar.

So you are doing your actual design work through a remote session instead of locally?

Your laptop is physically near the laser, this is the laptop that you’re working from directly, and you remote to a different desktop far from the laser that LB is installed on?

And yet LB is installed on a computer physically far from the laser?

I’m sure there are reasons for this but some of this seems backwards.

  1. I would think you’d want to do your design work locally as to minimize latency
  2. typically you’d have LightBurn run from the computer physically close to the laser

Any particular reason for your setup?

I don’t design anything in LB, all SVG imports.
Yes the popups are local as well.
I have used multiple previous versions of LB this way for 2 years.
Pop ups didn’t show up till 1.1.01

Interesting, I can’t close the blank popups, but if I minimize LB, and then open back up they are gone.

Also, if LB is minimized prior to opening RDP session, the popups don’t exist when maximizing LB. It only happens if LB is full screen when RDP session connects.

I’m guessing these aren’t actually windows then, just a drawing artifact. Have you recently upgraded your graphics drivers?

Or possibly a change in RDP version?

Try downgrading LB to confirm it’s something unique to the version change.

Yes, they are windows, and yes, I can move each around independently, just can’t click close button.

Yes, is specifically with ver 1.1.
No issues on when switching back, nor prior.

When clicking around inside them, even shows drop downs.

Interesting situation.

Not sure if Remote Desktop would be considered a supported use case but think @LightBurn will have to look at this.

Thank you for bringing this to our attention. We are investigating…:slight_smile:

Thanks Rick.
Guaranteed, I will not put a $3k desktop w/ 16 procs and 64gb of ram in a hot shop next to my laser.

FYI, This problem remains in 1.1.03.

Is there any reason you couldn’t use the laptop for lightburn directly?

If its doing it for me, its doing it for all, u just don’t see it w/ faster graphics.
The windows are Opening and Closing SUPER fast, dozens at a time, as I can sit and watch the CPU spike, and see the windows when hovering over taskbar icon.

Have we always been able to do multiple LB sessions w/ multiple files open?
Might be related.

One file in each session? Yes, at least for the last couple of years but I’d guess longer. Definitely not something recent.

I often work the other way around and RDP (or VNC) into the laptop in the garage that’s connected to my laser. Both machines are running Win 10 and LB 1.1.03. I’ve tried LB full screen, opening a layer cut settings window, closing the RDP session then opening a new RDP session and I’m not seeing any ‘phantom’ windows or CPU spikes etc.

Hope this helps @LightBurn or anyone else in their investigations.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.