Cutting ovals on rotary device not circles

I have a orion 60w laser with ruida controller.

I am having trouble making circles on a tumbler. The tumbler is not tapered. In the software it is a circle. When cut it is a oval shortened on the y axis which is the rotary axis. I have changed the diameter from 9mm to 90mm. Both print the same. I have changed the roller diameter from 100mm to 67mm. both print the same. I have tried enabling and disabling the rotary device. both print the same. I have tried it with cutting a line and with filling. both print the same. I’m running out of test tumblers. I don’t know what to do


First, stop using tumblers - wrap some masking tape around one and engrave lightly on that, replace as needed, until you get the settings right.

Second, changing the circle pulse or roller diameter should change the output if you have rotary mode enabled. If it’s not enabled, it’ll have no effect.

Which model of Ruida controller do you have?

First thank you for the tip. I have taken notes and will use it.

Second, how can i determine my Ruida model?

6445 G


@trcmag here you go

When you connect in LightBurn it says something like “Found RDC644xG” or similar on the bottom status bar, roughly in the middle of the display. There’s also a reflective sticker on most of the control boxes (inside the machine, with all the wire connections) that will show the model number.

I have a 644xg.

Thank you for the solution. It seems that the rotary mode was not enabled.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.