Default com port

When I connect to my laser lightburn always defaults to com 6.
Is there a setting so it will default to com 3 ?

Interesting question.

On my grbl machines, it appears to read what’s available for a connection. Don’t know if there is a default that you can set. Most machines dynamically create com ports as needed, at least Ubuntu does. I’d think that would be common.

That’s on my Ubuntu.

I looked at all the areas I know of and don’t see anything that allows that to be changed. I also searched the .ini and .lbset files and didn’t see anything with ‘com’ in them.

Sorry, it appears not…


Thanks for the reply.
Seems kind of weird that the software always defaults to com6
It sees the port but I always have to select it.
Could it possibly be something with my laptop?
It’s obviously not the end of the world, but it just got me to wondering why it does tis.

From what I can ‘see’ it will only put up usb ports that exist. Does com6 always exist?

Maybe one of the @LightBurn people can answer this for you…


com 6, 5, 4 and 7 are always there.
Its when I connect to my laser that com 3 shows up.
And that’s the one I need.

LightBurn will show whatever Ports are made available from the OS. The port for the laser is being made available dynamically when the device is plugged in.

You can see this in Device Settings. You’ll only see the port available when the device is plugged in. Sort out a way to keep it permanent at the OS level and LightBurn will see them fine.

For a static port might try… I’m assuming a windows machine, something like

For a Linux box you need to check out how to set up ‘udev’ rules.

Good luck


Port number assignments are apparently a function of the driver in Windows. And in general they try to retain port number for a given device. However, static port number is different than persistent port presence which is I think what @JVL is after.

Thank you for the help guys.
Like I said, it’s not the end of the world, I’m just curious as to why com 6 doesn’t show up.
My laser is a J-Tech 7 watt, attached to my 750 X carve.
Running a windows 10 laptop.
You a funny boy.
I don’t even have half a clue as to what your trying to convey.
That’s light years away from my comprehension.
But I do appreciate the reply. (makes me realize how much I don’t know)

Sorry, I didn’t take it as a joke, and certainly wasn’t trying to insult you.
Rather, I kind of scratched my head because I have no idea what that means.
But again, I appreciate the reply’s.
Maybe I can learn something from them.

Whatever port you used last is what LightBurn will default to when it runs the next time, assuming that port is actually available. If you are running LightBurn and then connecting / powering the laser, the port wouldn’t be available when LightBurn runs, so it wouldn’t auto-choose that port.

Hi Oz,
Thanks for information.
I’ll have to go out to the shop and try that.
But to be sure, I always use the same port and the software always thinks that it is com 6

Well it looks like my problem is, was, the order that I was connecting to my laser.
This works perfect.
Thanks Oz.
We get to soon old and to late smart.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.