Default laser rrrrrrrrrrrrrrrrr

Why is it that when I chose my laser and set it as the default, the setting doesn’t stick.
I have to chose it and then set it as the default every time.

Not a good idea to combine nor double post questions. It makes us have to work harder than we should. Please don’t do that. We will get to every post. I started to address this in another of your posts on the same issue. Please review and respond there.

I just tested this and am not seeing this issue. This is working in version 9.15 as expected for me running on Mac.

I have not tested this on Windows as of yet.

I set my default to TopWisdom profile, quit LightBurn and when I relaunch, TopWisdom is the profile that is loaded and the default profile. If I set the profile to any of the others I have, quit then relaunch, the TopWisdom profile is loaded as it has been set to default. Note: Default is marked with an ‘asterisk’.

If I then change the default to Ruida profile, every time after that, Ruida will get loaded as the default.

I don’t have a clue as to what “Top wisdom” is.
Where do I find it?
What is it supposed to do?
All I know is when I open up the program and produce a file, it will always ask me for my laser. I have only one laser.
I click on it, and set it as my default, the next time i start the lightburn, and try to save a file, it asks me the same question.
Its not a show stopper, but just think that something is not working quite right.

TopWisdom is one of the laser controllers we support. I used this profile as an example, that all.

You are saying that you set the profile you have defined for your laser as the default? Click the ‘Devices’ button in the ‘Laser’ window to expose the profiles you have defined. You should see an asterisk next to that profile after you have set it to be the default. Are you saying you are not seeing this indication and this profile is not being set as your default?

What version of LightBurn and what OS and version and you running on this computer?

hi Rick,
Thanks for the reply.
My machine is an X-Carve with a J-Tech 7 watt laser
Computer is windows 10
This is my device window.


Every time I make a new file, this window pops up and I will always chose to make it my default device.

Just did another set of testing on a Windows10 based system running LightBurn 0.9.15 and am not able to reproduce this issue.

Things are working as expected. Once set, LightBurn is loading the default profile on each launch. If I change the default to another profile, the new default is the one that is loaded when you launch LightBurn.

@LightBurn, thoughts?

interesting.
so what is it that I could be missing?

Are other settings not being retained as well? For example, if you change the black layer to be 12% power, then quit and re-start, is the black layer till 12% power? If not, your settings are not saving. Do you have really aggressive anti-virus software, some kind of domain user policy, or something like that?

The other setting appear to be just fine.
(other than “user origin” changing by itself)
Its’ not the end of the world, but I thought it strange that every time I start a new file I have to once again set my laser as the default.

Edit.
Guess I didn’t answer your questions.
As far as the virus and domain questions, I have never had any issues before.