Design displacement

Hello there,

I’m having big problems with Lightburn. Some of the designs are displaced when engraving, although they look fine in Lightburn. After the displacement the engrave goes back to the original place. I though it was maybe a connection problems with an axis but it happens in the exact same place if you repeat the job. Here is a picture with the problems showing:

I can’t attach a picture with the design on Lightburn because the number of images appears to be limited for new users.

If I ran the job on RDWorks everything works fine.


How are you connected to the controller? USB or Network? It’s possible you’re getting errors when sending to the machine.

I’m using USB but I’ve been using the same method with RDWorks for 3 years and I’ve never had a problem like this one.

There are two connection types: Serial/USB and Packet/USB, and some controllers prefer one over the other. If you go to the devices list and double click your controller, try the other connection type and see if it behaves better.

I just have one option for USB:


I can’t see the Packet/USB option. Am I doing something wrong?


What version of LightBurn are you using?

The latest. v0.9.04

Ahh - I only have the packet option on the PC, as the Mac drivers only allow having one or the other. You didn’t mention that you were on a Mac - you might need to update the FTDI driver.

OK, thanks! I’ll give a try. So Packet/USB is better than Serial/USB then? Thanks

Not better, just slightly different in the way it communicates. Most controllers are fine with Serial/USB, but once in a while I find Packet/USB works better with certain controllers. The opposite is also true - I’ve had Serial/USB work fine and Packet/USB fail on some controllers.

Ok, thanks. Is there any condition where I can be 100% sure than there is not going to be communication problems? Will Ethernet do the job? I mean, I’m using Lightburn for business so I can’t risk a job every time I send something to the machine.

By the way, I’m using the 644XS controller. Just for the record or if you know any known problems about this controller to let me know.


Where is it at on the table when you have issues. Mine is doing it at the front left not sure what is causing the issue works perfect everywhere else except front left it gives me a double cut about .100 from where it should be.

No, there is no way you get that guarantee even with the stock software. You can minimize issues by using a good quality USB cable, no more than 10 feet long, preferably 6 feet. Ethernet is significantly faster, but uses UDP instead of TCP, so there isn’t as much error detection / correction happening.

I would suggest trying LightBurn on the same PC that you run RDWorks from, as that will remove variables. If it works flawlessly on that PC, but has issues on the Mac, then I’d look for things on the Mac that could affect it, like USB port sleeping, making sure the drivers are up to date, and so on.

Thanks Oz.

Here is the funny part of the story: I’m using RDWorks in a virtual Windows 10 running on Virtual Box on the MAC so they are both sharing same hardware and cable (the cable is quite long indeed, 5m/16 feet). Probably the way that Windows manage the USB port is different that in MAC, I don’t know.

I tried to update the driver on the MAC but I still can’t see the Packet/USB option in Lightburn so I’ll give a try to the Ethernet. If it doesn’t work, unfortunately I have to stop using Lightburn.


The packet option won’t be available on the Mac, but updating the driver could help the communication regardless. It’s also worth seeing if the issues happen when running LightBurn from the VM. Email your license key and we can lift the VM restriction.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.