Design not 1on1 with output

Hi, running LB 1.5.06 and when designing objects in LB the input and output via the laser are not the same. E.g. when making figure of 8cm * 5cm the laser doesn’t make a 1:1 cut for me, the actual cutting will be 5.6cm * 3.7cm… Anyone suggestions because, despite new install and setting everything back to default the issue persists.Running LB on MBPro.

image

hello,
Maybe you should check your setting of the parameter of your step motor

Make sure you have all settings set correctly (no conversion from inch to mm anywhere) and as Allen suggested, most probably your steps/mm values are not correct. This setting depends on your laser hardware and should be somewhere in the documentation. You can also show the output of the $$ command in the console window here. Then we can have a look.

Hi Allen, tnx for your swift reply and reply. Me being not really familiar with this wil resolve in the following question. Hoe do I do that? As far as I knie I made the basic settings in the initial setup. Do I need to dive in this again?

Hi Melvin, will dive into it and let you know. For now, tnx.

Hi all,
thnx for helping me out. Had a look at the preferences but cannot find anything. What is parculiar is when set with and height to 21.025 mm or 29mm I create exactly a square with resp 10mm and 20mm measurements. Seems there is a “disturbance” or correction ratio of 1.45. But I can not find in the preferences where I can correct this to have a 1:1 ratio.

The setting you are looking for is “steps/mm” for both axis. Go to the console window, enter $$ and press the return key, then copy the full-text output here. Then we can take a look at those values.

Melvin, tnx for your support. This is the info from the console window:


Waiting for connection…

Port failed to open - already in use?

Waiting for connection…

Port failed to open - already in use?

Waiting for connection…

Waiting for connection…

[MSG:X Axis Standard Stepper St

Grbl 1.1 [‘$’ for help]

ok

[VER:1.1.2022010301:]

[OPT:PHSW]

[MSG:Using machine:LGT RAY]

[MSG:Mode=STA:SSID=:Status=Not connected:IP=0.0.0.0:MAC=94-B5-55-AB-35-EC]

[MSG:Mode=AP:SSDI=MKS_DLC:IP=192.168.4.1:MAC=94-B5-55-AB-35-ED]

ok

Project loaded in 0 milliseconds

<Idle|MPos:0.000,0.000,0.000|FS:0,0|Pn:PX|WCO:0.000,0.000,0.000|PS:100|PF:100>

ok

<Idle|MPos:0.000,0.000,0.000|FS:0,0|Pn:PX|Ov:100,100,100|PS:100|PF:100>

ok

Starting stream

Stream completed in 0:12

ALARM:3

Reset while in motion. Grbl cannot guarantee position. Lost steps are likely. Re-homing is highly recommended.

ok

Grbl 1.1 [‘$’ for help]

[MSG:‘$H’|‘$X’ to unlock]

[MSG:Caution: Unlocked]

ok

$0=10

$1=25

$2=0

$3=3

$4=0

$5=0

$6=0

$10=1

$11=0.010

$12=0.002

$13=0

$20=0

$21=0

$22=0

$23=0

$24=25.000

$25=516.000

$26=250.000

$27=1.000

$30=1000.000

$31=0.000

$32=1

$37=1

$38=1

$39=1

$40=100

$41=40

$42=1300

$43=5

$44=1

$100=250.000

$101=56.000

$102=250.000

$103=100.000

$104=100.000

$105=100.000

$110=56.000

$111=6000.000

$112=1000.000

$113=1000.000

$114=1000.000

$115=1000.000

$120=600.000

$121=500.000

$122=10.000

$123=200.000

$124=200.000

$125=200.000

$130=410.000

$131=410.000

$132=200.000

$133=300.000

$134=300.000

$135=300.000

ok

ok

ok

ok

ok

<Idle|MPos:-52.857,-11.839,0.000|FS:0,0|Pn:PX|WCO:0.000,0.000,0.000|PS:100|PF:100>

ok

<Idle|MPos:-52.857,-11.839,0.000|FS:0,0|Pn:PX|Ov:100,100,100|PS:100|PF:100>

ok

Starting stream

Stream completed in 0:02

<Idle|MPos:-11.839,-11.839,0.000|FS:0,0|Pn:PX|Ov:100,100,100|PS:100|PF:100>

ok

<Idle|MPos:-11.839,-11.839,0.000|FS:0,0|Pn:PX|PS:100|PF:100>

ok

Starting stream

Stream completed in 0:01

Starting stream

Layer C00

[MSG:Program End]

Stream completed in 0:01

Project file saved as testenspeed.

Starting stream

Layer C00 Pass 1 of 15

Layer C00 Pass 2 of 15

Layer C00 Pass 3 of 15

Layer C00 Pass 4 of 15

Layer C00 Pass 5 of 15

Layer C00 Pass 6 of 15

Layer C00 Pass 7 of 15

Layer C00 Pass 8 of 15

Layer C00 Pass 9 of 15

Layer C00 Pass 10 of 15

Layer C00 Pass 11 of 15

Layer C00 Pass 12 of 15

Layer C00 Pass 13 of 15

Layer C00 Pass 14 of 15

Layer C00 Pass 15 of 15

[MSG:Program End]

Stream completed in 0:23

<Idle|MPos:0.000,0.000,0.000|FS:0,0|Pn:PX|WCO:0.000,0.000,0.000|PS:100|PF:100>

ok

<Idle|MPos:0.000,0.000,0.000|FS:0,0|Pn:PX|Ov:100,100,100|PS:100|PF:100>

ok

Starting stream

Stream completed in 0:02

Project file saved as testenspeed.

Starting stream

Layer C00 Pass 1 of 4

Layer C00 Pass 2 of 4

Layer C00 Pass 3 of 4

Layer C00 Pass 4 of 4

[MSG:Program End]

Stream completed in 0:07

Project file saved as testenspeed.

Starting stream

Layer C00 Pass 1 of 4

Layer C00 Pass 2 of 4

Layer C00 Pass 3 of 4

Layer C00 Pass 4 of 4

[MSG:Program End]

Stream completed in 0:07

Project file saved as testenspeed.

Starting stream

Layer C00 Pass 1 of 4

Layer C00 Pass 2 of 4

Layer C00 Pass 3 of 4

Layer C00 Pass 4 of 4

[MSG:Program End]

Stream completed in 0:07

Starting stream

Layer C00 Pass 1 of 4

Layer C00 Pass 2 of 4

Layer C00 Pass 3 of 4

Layer C00 Pass 4 of 4

[MSG:Program End]

Stream completed in 0:07

Starting stream

Layer C00 Pass 1 of 4

Layer C00 Pass 2 of 4

Layer C00 Pass 3 of 4

Layer C00 Pass 4 of 4

[MSG:Program End]

Stream completed in 0:05

Project file saved as testenspeed.

Starting stream

Layer C00 Pass 1 of 4

Layer C00 Pass 2 of 4

Layer C00 Pass 3 of 4

Layer C00 Pass 4 of 4

[MSG:Program End]

Stream completed in 0:06

This is the problem. These values define the steps/mm values for x and y axis. For most lasers, those should be identical. And, a common value is 80. 250 is the firmware standard, that is not applicable usually. Check if you can find any documentation of your laser, which values are correct. You can also calculate by yourself or let LB compute for you. Open machine settings and select “axis calibration”. There you can enter your values and change the steps.

Melvin, tnx a lot for your help and support. I will dive into it and see what the original or most appropriate settings should be.
reg, Gerard

Hi Melvin, an update. I have tried with your suggestion and set to 80 on the $101 and is now exactly working accordingly. I will try to print other objects but seems to look fine. Again tnx a lot.

1 Like