Desperation Setting In - New User, Can't connect Lightburn to Laser

Help!
I’m new to Lightburn but not new to lasers.
I have spent 2 days trying to connect Lightburn on my iMac to the Ruida controller on my Mira 7.
I’ve read through other posts here in the forum and tried the different fixes (tried a different version of LB, tried connecting over Ethernet - setting up a new IP, etc…)
Nothing is working.
The UI says No Device Found; Files fail to transfer.
The ONLY thing I’ve done successfully is look at the inside of my machine from the Lightburn camera.

Any suggestions are welcome at this point, as I have orders piling up while I fiddle with this!

Sorry to hear you are having difficulties getting this going as you’d expect. What version of LightBurn did you try? What macOS are you running? We recently had some communication issues with Mac’s using DSP control systems, which have been address in our latest release. All that have tried this release are reporting no further communication issues so far, and looks to be resolved. If you haven’t tried our most resent release, (download from Trial page here: Download & Trial - Try before you buy – LightBurn Software) please do and let us know how that goes. :slight_smile:

Share a bit more about what you have, and we can go from there.

Hi -
I’ve tried the last few versions of Lightburn. So 9.24, 23 and 22.
I was running Catalina, but now I’m updating to Big Sur and will try everything again.

Understood. When you can, please update us on your progress. Here to help. :wink:

1 Like

That did it! You must be running Big Sur and the latest Lightburn for them to connect!
Thanks for helping!

You are welcome, no worries, we are here to provide a hand. Glad to hear you are sorted and things are working as expected. Let us know when any future questions arise. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.