Device Discovery Wizard can't find xTool D1

The Device Discovery Wizard in LightBurn 1.2.00 can’t find my xTool D1. I’m on a iMac running OS Monterey (12.4). Everything is connected, plugged in and I am at a complete loss. I’ve been beating my head against this wall for 5 days. Help!

Have you tried using the xTool provided .lbdev file to configure the device?

You can find the link to the file in the User Manual page:
User Manual for xTool D1 LightBurn Software – xTool

I can’t get to that step. The Device Discovery Wizard window comes up immediately upon opening LightBurn and that is where I get stopped.

Can you take a screenshot please? I thought “import” was one of the options on that screen.

OK I did it! Here are the steps I used
1 - Deleted Laserbox and LightBurn and reinstalled everything
2 - Opened LightBurn and saw the usual Device window - clicked “Import” in that window not the “Devices” field as shown in the User Manual.
3 - Imported the .lbdev file
Now it works

Thanks for your help!