Device displays "Disconnected" in laser control panel

I use a K40 Laser cutting and Engraving machine. Cohesion3D Mini board. My laptop recognize the device as a “Smoothieboard”.

In Lightburn, on the laser control panel the device displays as disconnected.

Can you please assist me in rectifying this issue?

Right-click the ‘Devices’ button in the lower-left of the ‘Laser’ window to reset the current device connection. Is this not working for you?

image

Where it says ‘Auto’, you might have to choose a COM port - sometimes this is enough. If no port is showing in that list then you may need to install drivers, or might have an issue with the board itself, like the firmware isn’t flashed on the SD card, or the SD card isn’t inserted - either of these things will prevent the board from being recognized by the computer.

Thanks for coming back to me. It doesn’t give me the option as showed on the print screen.

Thanks for coming back to me. It doesn’t give me a port to choose. I’ve bought the machine and the software as second hand and I am not clued up on what is supposed to be on the SD card. The SD card came still inside the machine, can you please tell me what firmware should be on there and then if I need to download a driver can you assist me on what driver should be the correct one? I am using windows 8. Cohesion 3D Mini board.

For Windows 8 you don’t need a driver. There is a MicroSD card that should have come with the Cohesion3D board that contains the firmware that runs the board.

All of the instructions and files for the Mini are available here: https://cohesion3d.freshdesk.com/support/solutions/articles/5000726542-k40-upgrade-with-cohesion3d-mini-instructions-

All the way at the bottom is this text and link:

The K40 Upgrade Bundle comes with Smoothieware CNC Firmware and a K40 Laser-Specific configuration file on the included MicroSD Card. Here are those files: https://www.dropbox.com/sh/7v9sh56vzz7inwk/AAAfpPRqu63gSsFk3NE4oQwXa?dl=0

Those are the files to put on the SD card installed in the board. When you plug in the board you should hear Windows make the telltale ‘Bing!’ that means it recognized a new USB device.