Device settings

Dear All , I have experienced LightBurn and my Neje engraver connection problem again after working on it for several hours. In the Device settings there are names such as Neje 20S, Grbl, Grbl (there are 6 Grbl in the Device box). I’m not able to delete them and keep only one. If I delete the whole LightBurn software and reload again will it help. I will also clean up the USB connection, change a new cable and hope this will fix the problem. Thank you

Are you referring to the Devices window? Asking because Device Settings is a separate window specific to an individual laser.

What’s preventing you from deleting them? Are you clicking on the name of the laser in Devices window and then clicking “Remove”?

Most likely not. You haven’t explained the issue that you’re having but it’s not likely related to the software being installed.

What is the exact nature of your problem? Can you confirm that the laser in question is the Neje Master 2 in your profile?

Can you confirm you have the latest firmware installed for your laser? Have you reviewed this article from Neje about connection issues?
Solution of NEJE Master 2 Serises Device Stop Working – NEJE (neje99.com)

Thank you for your reply. Sorry I should have attached a screenshot. But the Device I mentioned is related to Grbl setting that shows up on the bottom right corner indicating which setting was selected for my Neje Master 2S machine. Every time I reset it to get it to work it will display in the Box & because I encountered “Waiting for Connection” display in the Console screen when I turn on to use there is no immediate connection with LightBurn and I cannot use. I had to go in to this window and select the correct one. As there are a long list of one Neje 2S & 8 Grbl I have to go through to select. If I cannot select one that work I begin to suspect my cable is faulty etc. To avoid loosing time I would like to delete all those that cannot connect and keep only one. When you ask if I have click the name in Device window you refer to the box at the bottom left side of the screen .? If yes where is the “Remove” sign for me to use . Can you be kind enough to sent a Screen Shot please. I’m using Neje Master 2S and also download the Neje software to work. It was working before. I’m doing this as a hobby and only have time during weekends. If you sent me anything to fix I can only reply you after the weekend. Thank you . Very kind of you.

Push “Devices” button in Laser window. Once you push that you will get a list of all the devices you have setup. Click the device you want to remove and then select Remove.

Dear Sir Further to your email and screenshot above, I managed to get the system working now. Thank you. One thing I cannot understand is there are times where I still get no connection and have to reload a new Grbl to connect, and then go to “Devices” to delete the first one. Is this normal.? Thank you.

No. You should never need to do this.

Two things to check:

  1. Make sure that the correct port is being displayed. If you start LightBurn without the laser on it will refert to “(Choose)”. You can avoid this if you always start LightBurn only after you connect and turn on the laser. For me that’s impractical.
  2. If the port is correct you may need to just reconnect. You can force a reconnect by right-clicking on “Devices” button.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.