Disable the space bar for starting the program

I know this has been commented on probably many times in the past but the space bar has got to be disabled for running jobs. I’ve ruined so much stuff because of it. I’m pretty much in the habit now of hitting the mouse instead of the space bar but still every once in awhile when the monitor has gone to sleep I hit the space bar. It’s just a hard habit to break. Please disable the space bar for starting a job so I can save money, time and aggravation.

Are you saying that if you press the space bar, LightBurn will send the currently open job to the laser? Please describe the process and steps you use, so we can try and reproduce here.

Looking into this a bit while awaiting your response, we see that the Start button can continue to have focus even after you pressed it. When the screen sleeps, hitting the space bar in this condition, would trigger the focused button. At this point, tap the CTRL key or moving the mouse is safer.

We are looking into ways to have this behave as you suggest and hitting the space bar would just wake the screen.

plus one for this

i have frequently tried to wake up the screen , and the laser had started cutting instead.

it’s the only time i have to use the emergency stop.

On Windows, I’ve added code to track whether the monitor is asleep or not. If it is, Start, Stop, and Pause will now be ignored.

I wake my display by pressing shift or ctrl, or (moving the mouse) for this reason - They don’t trigger an action. In Windows, if a button or control has the keyboard focus, pressing the space bar will trigger it.

wow Oz

your customer care is AMAZING

i would like to say, As a user of many software packages across many diverse areas , i have come to generally dislike the subscription model for software, for many reasons.

however i am THRILLED to be paying subscription for my Lightburn , for three reasons

1- your pricing is set at a ‘hobby’ price even though the quality is set at ‘professional’.

2- your reactivity to user requests is beyond any developer i ever worked with.

3- you regularly and consistently add so many brilliant new features.

Thanks to you and your team for all you do.



LightBurn is actually not a subscription model. It is an update model. If you purchase LightBurn you can use it forever but you will not have any updates after that initial purchase year.

1 Like

thanks for clarifying that HN, you are absolutely correct.

that’s an even bigger reason to love Lightburn.

the other thing i meant to add is how flexible they are if someone needs an extension to the trial period etc

i love the customer care.


1 Like

Ok. Thank you. If and until the space bar gets disabled, I will move the mouse off the start button once I’ve started a job.

Moving the mouse won’t do it - When you click the start button, it becomes the ‘focused’ control, IE the last thing you touched. You can press the ‘Tab’ key on the keyboard and watch the little highlight move through the different controls in the UI. When you press the space bar, the currently active control will interpret that accordingly. Buttons will treat it as a button press.

The best way to prevent the space bar from triggering the start button for now is to click in the edit window after you click Start, so the edit window takes the keyboard focus. Space bar in the edit window is benign.

1 Like

Please do not disable this option, I use it all the time. Great for repeating jobs, I put in new material and then just need to slap the space bar to run it again.

Your solution to disable when screen is asleep is excellent. I enjoy your constant improvements and great communication!

I just don’t let the screen go to sleep… :slight_smile:

I know people use it, so I didn’t want to remove it (though Alt+S also starts the job, and works even when the button doesn’t have the focus).

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.