Discrepancies in times

I am having an issue with discrepancies between the estimated times in the Preview and the actual time it takes to burn. The preview shows a much lower time than the actual burn, by a large margin. This started yesterday. I haven’t changed any settings so I’m not sure what the deal is.

This piece actually took well over an hour to complete.

Plus, the final outcome is an unrecognizable burnt blob. You can see my settings in the upper right corner.

Any and all help is very much appreciated.

If you’ve never set the preview in LightBurn to match your machine settings, that’s one issue. Go to Edit > Device Settings, click ‘Additional Settings’, then ‘Read from controller’.

Second possible issue - If you’re using a device that is normally a CNC, you likely haven’t enable “laser mode” - Setting $32=1 in the console tells GRBL not to pause with every power level change, because it doesn’t have to wait for the rotary spindle to speed up or slow down - lasers react instantly, rotary tools don’t, so you need to tell the controller what tool is connected. $32=0 is normal spindle operation, $32=1 is laser mode.

Another possible issue is (guessing here) that you have an 8 bit Grbl controller, and they simply choke when doing image engraving at any reasonable speed. An 8-bit Grbl device can process up to about 200 instructions per second. With dots sized 0.1mm (254 DPI), 20mm of image can produce up to 200 instructions of GCode, so you may hit places in the image where the dots perfectly alternate, and your speed would drop to a maximum of 20mm/sec (1200 mm/minute). You’re using 0.08mm interval, or 318 DPI, meaning your possible speed cap could be as low as 16mm/sec (960 mm/min).

That’s not a settings issue, and there’s no automatic way for LightBurn to know that you’re connected to an 8-bit device with limited processing speed.

I’ve been using my machine for several months and have not had this problem. I have produced several nice pieces and the times were fairly the same. This started day before yesterday. I’m just curious as to why this just started doing this.

You’ve engraved dithered images at 318 DPI before with no time issue?

Yes. I prefer to process my images in LightBurn as compared to ImagR. And depending on the details in the photo, I have used 318 DPI with no issue.

It is doing it here as well and there is no dithering. It is taking almost 3 times the approximate time stated in the preview. I would really appreciate getting this figured out soon.

The very first thing I wrote was the above - have you done this? It’s necessary to do that to make the preview match the machine.

It’s also possible that something in the machine settings has changed, or is limiting your speeds. Type $$ in the console and press enter, then post the results here. Having $32=0 would make engraving jobs go much slower, as would having low speed limits set on $110 or $111.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.