Disegno inclinato a 45°

Non riesco a capire se è un problema hardware/firmware o software…

Ogni disegno che faccio è orizzontale su lightburn, ma la stampa è inclinata a 45°

Secondo voi da cosa può dipendere?

Can you show screenshots of the problem?
(Google Translate) Puoi mostrare schermate del problema?

Do you have “Print and Cut” enabled? Look in the top of the Laser window on the right, where it says “Ready” - does it say “Print and Cut” there?

Try this - In the console window, type the following commands:

G0 X0 Y0
G0 X100 Y0

That should move the laser to 0,0 after the first command, and then move 100mm to the right. If it does not move perfectly to the right, then there is something happening in the controller itself, not LightBurn, that is causing this.

yes, it moves at 45° and it’s not correct …
what will it depend on?
Yesterday I tried to install the eleks rotate module … that some parameters have changed?
I also tried to update the original firmware but nothing …

Thanks anyway

“The eleks rotate module”? I do not know what this means, but it is quite possible that the firmware or something else has changed. Did you alter the wiring? I can’t think of anything in GRBL firmware that could cause this.


Eleks rotate is the one in the photos, and on lightburn I enabled rotation, then I disconnected the Y motors, and I connected the rotate engine of eleks rotate, on Eleksmaker’s Mana card.
Finding that he was drawing at 45 ° I put everything back as it was on the plane and it does the same thing to me, so I thought I had touched some parameters.
now I see what I can do

I found the solution but now I have to understand how to solve the laser / draw option only with lightburn.
I opened the original elekcam software to select the type of machine and if I select eleksdraw it moves at 45 °, while elekslaser at 0 ° then I have solved this.
The second problem is that I have to use this software to switch from laser mode to servo mode to use the pen otherwise it won’t move with the laser on / off command.
Is there an option to switch this mode in lightburn?
thank you

I would need to know what commands it’s sending to know how to do that - this is apparently a custom application producing specific gcode to drive their machine. Is there a way to save gcode from this software? If so, you could draw a circle and save the gcode for it, and I could look to see what commands are used for the pen. I can’t guarantee there will be a way to make it work, but there might be.

I don’t understand how to create a gcode with elekscam … I see that you can import gcode files in .nc format
I tried to give a G2 command in semiautomatic as you can see in the photos, but I don’t know if it can help you.
Another thing: it would be useful to have a Laser On / Laser Off command on the lightburn screen, as in elekscam, so that you can directly control the pen or laser in real time.

That would be incredibly dangerous. For a pen it’s not a big deal. For a laser (the thing LightBurn is designed for) it’s fire and blindness waiting to happen. There are functions for enabling the laser for focusing for framing, but I’m not interested in interactive control of the laser.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.