Do you have problems with camera calibration settings staying persistent?

Hi all,

This is more of a statement and no one needs to respond if they do not want to.

I have been having trouble with my laser alignment since I changed laptops about 2-3 days ago. I’ve never had a problem with my alignment before as it’s been working perfectly for a month or more. When I changed my laptop and to a new version of Lightburn I’ve noticed that every time I either turned off my laptop or laser, when I turn it back on and print, the alignment or calibration(or both) is off significantly. I’m not sure if this is because I’m turning off my laser, my laptop or because I’m closing the software.

If you are having this problem, you can recreate the issue the following way and you can use the workaround I have here. I’ve seen lots of posts about this where the problem was blamed on a lid or something moving on the user. But the steps I took, took movement out of the equation as I was able burn as expected, to recreate the problem, fix the problem and recreate the problem again, all without touching the laser machine.

My steps and the workaround:

  1. Calibrate and align camera. Add stock (I used a 2x4) to a burnable corner of your bed. Update overlay. Export camera settings (right click on the camera view in camera control… there’s a menu in there). Align design (I did a 1/4 inch or 6mm circle with fill) to stock on overlay in working area. Once you close this lid, do not touch the laser machine unless it’s the power button.
  2. Burn. Confirm precise replication on stock (Update overlay, turn off fade, then show/hide layers that were burned to see the circle you drew is exactly over the circle the laser drew). Expected behavior.
  3. Save your file. Do not burn.
  4. Turn off laptop and laser machine. Do not touch the laser machine.
  5. Turn on laser and laptop. Open file in Lightburn. Burn.
  6. After burning confirm precise replication. This fails with unexpected behavior. The circle on your screen does not match the circle the laser drew.
  7. Import camera settings from step 1 (right click on camera in camera control, Import).
  8. Burn on same stock over previous burn. Confirm precise replication. Expected behavior.
  9. Turn off laser machine and turn off laptop. Turn it back on.
  10. Burn on same stock. Same result in step 6. Unexpected behavior.

Work around:

  1. Calibrate and align camera. Export the camera settings immediately.
  2. Every time you go to use lightburn, import the camera settings.
  3. Since I’ve been doing this, I cannot replicate the problem.

If you are having this issue and you know that your camera is mounted correctly, try this workaround and it should work for you. I’m happy with this workaround and don’t need anyone to fix the issue, just trying to help out those that are still struggling.

Before doing this step, verify that your file is using ‘Absolute Coords’. If it is not, this is not a valid test.

I have verified numerous times that the numbers do not change, ever. If you draw a mark on a wall and mount the camera on a shelf facing it, it will not move and the calibration will not change. I have had other users like yourself repeat this experiment with the same outcome, and it’s the only thing that seems to convince anyone that I’m not lying. :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.