Does anyone have or is familiar with the Annoytools 10 watt diode (dual laser) machine

I have the Annoytools 10 watt laser (dual laser) which has been a major problem for me with support. The company does not even have a website, and the email address I finally was given is a Microsoft Office account . . . not even a company account.
Does anyone else out there have one of these, and do you know if there is a profile available for this machine to give some idea of settings for different materials? It has a GRBL controller, which is as much as I know. Right now the controller has died, and I have been waiting for 3 weeks for a replacement from China!

Do you have a question?

A link to your machine is always helpful. Picture of the control board if possible… even if dead

Most of these work alike in a lot of areas and we can usually help you.


If you controller is dead, there isn’t much you can really do… until fixed

Sometimes it dies, but the ‘processing’ part of it works meaning you can log into it to read the configuration and find the version of the firmware. I have one I keep around…


Good luck

:smile_cat:

When you say the board died…what was the symptom?

It has been a long time since I had that machine. I do not remember any more what happened to the first controller. I finally recieved a replacement. I think I was able to burn one image to a piece of wood and then it started to “misbehave”. If you tried to “jog” the laser head, it would move left and right properly, and jogging toward the front of the machine worked, but if you attempted to jog to the back, the laser head/gantry would only move forward. If you attempted to burn something, any programmed forward movement also moved the head to the front. I had my contact from the chinese company log into my laptop remotely and control the machine, using my webcam to monitor things. He spent a couple of hours on it and indicated that it was essentially dead. I returned the controller and laser to him, and received a refund for the entire machine; I went out an purchased an Xtool D1! No problems so far.