Dual Head Support problems

Hi!

I recently got my chinese Ruida controlled laser cutter and was looking forward to learning Lightburn after using RDWorks for some time at my old makerspace…
INFO: 1300x900 bed size, 150W and 80W CO2 Tubes, Ruida 6442G controller

It seems like lightburn recognizes the two tubes, as I have the option to enable Laser 2. The problem is that I can not get only Laser 2 to fire. I can get Laser 1 to fire by itself, and when I try to enable Laser 2, both tubes fire.

Under the “cuts” box, I can select “Laser 2” and check “Enabled”. However, when I double click the layer in my cuts list to bring up the “Cut Settings Editor” popup, Laser 1 is ALWAYS selected. Even when I check Laser 2, check off “Enabled”, and click OK. Whenever I open up the Cut Settings Editor, Laser 1 is default selected.

To sum it up, the Cut Settings Editor popup is always defaulting back to Laser 1, which is making Laser 1 always fire. Under the Cut Info section, I can select Laser 2 and Enable, and this will fire laser 2, but laser 1 also fires. I can’t find a way to only fire Laser 2. Is this a big, or is there something I have to change?

FYI I am running Lightburn 0.9.07 on Windows 10 Pro. I have also set the Laser 2 offset in the settings, however it hasnt seemed to change the behavior of the machine…

note: From my understanding, the 6442S controller is supposed to have dual head support over 6442G, but the dual heads and laser controls work fine in RDWorks. The label on my controller is 6442G, however Lightburn recognizes it as Ruida 644XS. Not sure if that makes a difference or not, or it that means the controller is mislabeled.

If you need any more info, or if I can try anything different or test beta software I’m open to helping out!

When you say the cut setting editor is “defaulting back to laser 1” do you mean it’s showing you the settings for it, or re-enabling it?

There is a pair of radio buttons to show you which tube you are editing the settings for, and there is an ‘Enable’ button for each tube. If you only want to fire laser 2, you would turn off the Enable for Laser 1, then click the radio button to select the 2nd tube, and turn on the Enable button for that one. Have you done this and it’s not working?

Hello, I’m stepping in because I have the exact same issue. Chinese laser, Acctek AKJ1390, 1300 x 900, 150w and 60w tubes, Ruida RD6332G. Lightburn 0.9.07 recognize my laser as Ruida 644XG on windows 10.

in the cuts window, if I click laser 2 and enable, I open the “cut setting editor”, and also select laser 2 (who oddly, wasn’t already selected) and then click ok, it will not stay that way. If I immediately reopen the “cut setting editor”, it will be laser 1 selected.

I can get laser 2 working but at the same time as laser one. I could get laser 2 by itself by manually turning laser 1 off on the machine but it doesn’t count the offset and it’s annoying.

I don’t see a pair of Enable buttons, I only see one in the cut windows beside laser 2, and again, the same thing in the cut setting editor, only one beside laser 2.
(see the image)

David

There aren’t two ‘Enable’ buttons - Like the other settings, the Enable button applies to whichever laser you have selected. Click the ‘Laser 1’ button, turn off the Enable, then click the ‘Laser 2’ button and turn on the Enable. You’ve now disabled laser 1 and enabled laser 2. Click between the Laser 1 and Laser 2 buttons and the settings should update accordingly. Are you seeing that behavior, or is it doing something different for you?

Thanks for your reply Oz, I figured it out before seeing your reply, see below for what was the issue. There is a bug where the Enable toggle doesn’t change colours when you select between Laser 1 and Laser 2.

I haven’t tested my offset by sending multiple paths to both heads in one workflow. I have only tested laser 2 on low power because I am waiting for my ammeters to arrive so I don’t kill the tubes. However, I will say that I think my offset is working because when I “frame” my file, it is framed from the perspective of the Laser 1 head, but when I start the cut, my Laser 2 head moves to where Laser 1 framed the workspace. Hope that makes sense.

The confusion in my initial post (and hopefully will help you David) mostly came because I didn’t realize what the function of the Enable toggle was, and also the Enable toggle under the Cuts screen does not change colour unless you mouse over it after changing the laser selection from Laser 1 to Laser 2 or vice versa.

What I was doing wrong is I thought the Enable toggle was only for Laser 2, because it is beside the Laser 2 label and it wasn’t changing colour when I would click between Laser 1 and Laser 2. I figured out later that if I mouse over the toggle, it goes to the correct colour. What I learned was that the Enable toggle is a switch for BOTH Laser 1 and Laser 2 independently. So if you only want to fire Laser 2, you have to select Laser 1 and click the Enable toggle to un-enable Laser 1, then you have to select Laser 2 and click the Enable toggle to enable Laser 2, and enter the power and speed parameters you want to use for Laser 2. (The same steps as what Oz replied with)

A couple suggestions for future releases:

-Add a “Laser 2 Speed/Pwr” column in the Cuts window when two lasers are detected so that we can see the settings without having to select the Laser 2 radio button

-with the new column, grey out the settings for the laser that is disabled (similar to when layers are greyed out/dimmed when their output is de-selected),

  • when Laser 2 is Enabled and Laser 1 is disabled, to automatically have the Laser 2 radio button selected when you click on each layer or when you open the Cut Settings Editor window for a layer. That way you won’t accidentally change the settings for Laser 1 when you meant to change them for Laser 2, especially when laser 1 was not enabled. This is mostly relevant for people like myself and David who have dual tubes for cutting and engraving. Some jobs will be 90% engraving and having to select the laser 2 toggle every time you want to change the engrave settings is an easy step to miss (which I have done multiple times already while testing things out).

Now that I’ve figured it out, it is logical, but it just wasn’t very intuitive at first. I think having an Enable toggle under the Laser 1 and Laser 2 radio buttons would be more intuitive in general, and especially for first time users. That way you can see immediately what laser is or isn’t enabled, and enabling or disabling each laser would be one click instead of multiple clicks.

And I don’t mean to harp on the program, so far I am very pleased with LightBurn and decided to buy the full version since my trial expired before I received my machine… oops. I mainly just want to share my experience so that you guys can have some direction for improvements! Thanks for all your hard work!

That could work - I’ll see if I have the space in the UI for it. It’s getting a little crowded in there, and I’m trying to keep it within reason for people who have space-constrained displays. The column version is possible as well, but harder - I’ll need to expand the window and it’ll likely look strange for folks with a single diode or tube.

And I don’t take suggestions as harping - Customers are the ones using this daily for work or for fun, and not everyone works the same way I do, so I try to take all feedback with that in mind.

Which OS are you using? I’ve seen occasional issues on Macs with the UI not repainting when it’s supposed to. If you’re on a Mac, that might be what’s happening.

Ah, I should have clarified from my original post, I am in fact using Mac OS 10.14 Mojave.

In the original post, I was using Windows 10 because I wanted to re-download the trial to test out the software, as I had already used the 30 days before I received my machine (didn’t think that one through). But my workflow is all in Mac OS so I just purchased the full version so that I would be able to integrate my entire workflow together.

As for the column suggestion, I don’t know what’s going on under the hood or why it might not be possible, but the Laser 1 and Laser 2 radio buttons only appear when two lasers are detected? Would it not work to do the same and only show the Laser 2 power/speed column when two lasers are detected as well?

It would, but I need to have the space reserved to be able to show it (and allow room for German, which is very long) so the UI might look funny. I’ll play with it.

just want to say thanks to both of you, problem solved!

David

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.