Duplicates not removed

I have some obvious duplicates here that are not being found. Am I doing something wrong or is it the duplicate removing tool that is not working?Duplicates not recognized.lbrn (19.1 KB)

I can duplicate (heh) this with your example file, but it works if I create new images (square or closed polygon with lines) in the same file.

Did you create that within LB, or import?

Looks like the ‘Delete Duplicates’ is still having issues. I am aware the current iteration requires very exacting shaped to work, but your duplicate shapes are the same size, but you also have other issues with this file.

Is there a reason for having these shapes overlapping each other? This is a very simple design with very simple shapes. I count nine shapes but when I select the entire content of this file, LightBurn reports there are 17 items (highlighted in red at bottom-right).

I would hand edit this file to clean up the duplicate shapes. I have pulled this apart for clarity.


Some duplicates came in while I was designing. I just expected duplicate cleaner to fix. Thanks for checking.

The problem is that these aren’t duplicates, they’re overlaps:

I’ve offset a pair of them here to illustrate:

The duplicate removal tool in LightBurn needs the shapes to actually be the same nodes in the same places (within a tolerance, but a small one). What you have here is lines that overlap, but the node locations are different, which is why they’re not being picked up.

In this file, doing an ‘Optimize selected shapes’ and fitting to lines first makes all the shapes the same, and then the dupe remover does the right thing.

We’re going to have an improved version before too long that actually removes overlapping lines (and even partial overlaps) that will handle this, but that hasn’t been done yet.


Again, thank you.
Happy New Year!

Well, I tried Optimizing, closing paths, auto join, with different settings and still no duplicates found. I will just have to be more careful in design until the duplicate tool is refined. Thanks for now.

When you optimize, you have to give it something to do (a tolerance of allowed error). I slid the line-fit up by a single tick to 0.002mm and that was enough to remove the extra points along the lines, and then the duplicate remover did the job. I’m hoping to do the proper ‘overlap removal’ tool before long.

YES! Never thought to go so low as .002…helps to know what that does. Thanks again.

But, no matter what I do there are lines that will just not connect even though they appear to be touching. I’ll give up for awhile and work on my original drawing.
Wont worry about it until next year.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.