DXF file low quality in Lightburn

Hello! I design laser cut files in Adobe Illustrator, and many of my customers use lightburn. For some reason, the DXF versions have parts of the text missing.


It is a single line font, if that helps.
I’ve played around with different settings and did a bunch of research, but so far nothing has helped.
Any suggestions? Thank you!

You don’t have to export to DXF. Select all in AI and COPY. Switch to Lightburn and PASTE. There might be some issues with single line fonts that have been outlined in AI. Mostly duplicate lines. You can run delete duplicates in LB.

1 Like

Thanks for your suggestion. Any ideas on how to make that work for customers? I sell the files on Etsy.

Do you have Lightburn?

I have the free trial version - so it will work for now, but I was hoping to find a more efficient solution to avoid having to use LB to export. Thank you for the idea though!

DXF files exported from AI aren’t necessarily a good option for Lightburn. Lightburn does a good job of importing PDF files. Here is the one thing you can test with the AI DXF files in Lightburn. Look at Edit>Settings

Select the File icon, and then look at DXF settings. You could try changing the Auto-close tolerance and see if it makes a difference.

I would also test importing PDF files from Illustrator. I think it is a better alternative than DXF from AI.

2 Likes

Thank you. I offer the svg, dxf, and pdf versions of every design so I would think one of the above should work in Lightburn. I specifically design for the Glowforge, which isn’t compatible with LB, but other laser owners expect it to work here too so I’d like to do the best I can to offer files that are compatible everywhere. Thanks again for your help.