DXF Import and Cut Order

When I import this DXF from fusion it cuts and looks correct but the cut order is all over the place. Is there a way to adjust how it cuts. I have tried different ordering and optimization settings and it still cuts in really random order. I assume it has to do with how fusion export the DXF.

I have the dxf I can share but I do not know how to share it on this forum.

Any insight would be helpful.


This is worth a review:

Rick, Thanks, I have reviewed that. The cut planner works well if I draw the shapes. It has problems with imported DXF

The problem is that you’ve likely enabled ‘Order by Priority’ but haven’t set any priority values.

The last release had some debug code that slipped through in the DXF importer - it assigns the DXF object ID to the priority value for each shape that comes from a DXF file, so if you ‘Order by Priority’ on a DXF but you don’t reset the numbers, they’ll look random.

Once I removed the Order By Priority the cutting pattern was not so random/scattered.

Thanks for the insight.

Not sure if this applies to your scenario or not, but I draw in dwg (Dassault Systems AutoDesk). I save as dxf, then import into Lightburn. In Lightburn I change the line colors as needed, then usually set the cut order to order by Layer to cut elements of my parts drawings in the order (and speed/power settings) I want.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.