Dxf Import misalignment

Hi, just started with Lightburn. I am making labels and draw many rectangles with text in Autocad and then import the dxf. Most of the widths of the labels are the same so I “snap” all the edges/corners together to form a common cut line in Autocad, which saves material and saves cutting time.
I have “Remove overlapping lines” turned on and “Auto-close tolerance” set to 0.500.
The issue I have is once I engrave/cut the job, some of the rectangles are out of alignment with each other, so instead of one continuous cut along the top of say 5 labels (I know this is actually 5 separate cuts). I get a few that are joined/continuous but 1 or 2 that are higher or lower than the rest.
I know I can use the alignment tool in Lightburn, but this can be extremely time consuming. I was wondering if there is a setting I have wrong or something else I may have missed.
Also, possibly related, some corners cut much much slower than others, some corners look like the laser doesn’t even slow down, others, the laser speed looks to halve about 10mm before and after the corner.
Thank for any help.

Nope, this doesnt fix the problem either.

When you are drawing you or your program is creating separated artefacts or objects with disconnected nodes. LightBurn can only interpret your intentions based on your dxf file.

You might find that you can tidy this up in LightBurn using the node tools. https://lightburnsoftware.github.io/NewDocs/EditNodes.html

You should also checkout in settings the Auto Close Tolerance
You can find an interesting, and I think relevant thread here:

Perhaps you could share one of your dxf files or a LightBurn project file here for us to have a look at?

Thanks, I do understand what you are saying here, it is only that that are snapped together in Autocad, but then move when imported to Lightburn.
I know Lightburn can only do what its being told to do, I just thought there might be a tolerance setting that I could tighten up.

I do have the auto close set, and its working nicely.

This isn’t really my problem, I don’t have an issue with my lines not joining, my issue is that somewhere along the import/export process they move to a slightly different position from where I drew them.

Never mind though, I have found a guaranteed fix. I’ll just draw slightly differently in Autocad, instead of separate boxes, I’ll just do it all with continuous lines, then there cant be anything misinterpreted in either the import or export.

Thanks for your help though

1 Like

Yes, they do seem to look OK in Lightburn

Bankstown.dxf (291.3 KB)

Thanks, that sux, but fortunate (in a way) it is the laser and not me or the software, I just bought a new laser. Hopefully it will work how I want it to once I get it set up.

Thanks for your help.

I can see you are working with layered sign laminate, so I assume you are using “Fill” for this layer. What settings do you have set, speeds and powers? Are you using “Fill all shapes at once”, “Fill groups together” or “Fill shapes individually”? What orientation are you engraving at, are you asking too much of a Y axis for example? What sort of machine are you using? Is this a DSP or a G-Code based engraver? If its a DSP machine, are you sending the file to the machine memory or are you using “start” via USB?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.