DXF not seen by LB as closed so won't fill

If I select and “Close selected paths with tolerance” it does nothing. Not sure if I’m doing it wrong or LB.
Any Ideas?LT Wont fill.lbrn (279.7 KB)

Image made in Corel16
Seen as closed in RDworks.
If I import into RD works then export as .ai then import into LB it works as expected.

Try ungrouping everything, then using Auto-Join (Alt-J). If it came in as disconnected objects, closing them doesn’t work - Close is for a single shape that doesn’t quite meet back up at the end. Join is for a whole bunch of disconnected shapes that you want to turn into a single shape.

edited above. Works in RDworks and works in LB if export from RDworks as .ai.

Can you post the DXF file? (or email it to developer lightburnsoftware dot com)

Once it’s in LightBurn it’s hard to tell if it was connected shapes in the DXF or not.

I emailed it to you.
It works in LB if I save the file then import it back rather than opening it. So it is saving it as closed.

I take it back. Only if imported from RD does it work.

Here is something odd though:

If I copy the image and paste it into another instance of LB it DOES work.

Can you define “doesn’t work” ?

Oh - You’re saying it won’t fill? That’s because it’s completely disconnected shapes. The DXF you sent is thousands of small line objects. RDWorks when importing is connecting them - it has a joiner with a 0.1mm connect tolerance when importing. You can do that in LightBurn too.

Where is that command? …the joiner.

There’s a setting to do it on import (check your email) or you can do it after ungrouping - Edit > Auto-Join (Alt-J).

I already have the DXF import set to autodetect and auto close. I see it working upon import but same result…not closed.

ctrl J doesn’t do the job either. still says “open”

Were you able to get all of the layers to scan on your machine?

In the meantime I’ll use RD to export and import into LB.

Mine misbehaves as well. The problem is these:


I’ve skewed the middle to show what’s happening, but it looks like the auto-joiner is creating bow-tie shapes that overlap. I’ll have to see if I can detect this case and prevent it.


For now I will use.ai for export and import.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.