Eleksmaker - Homing works great - framing problem

Got a likely simple answer question that I can’t figure out.

Using Eleksmaker 3axis + the 32bit nano + eleksmaker extra with limit switches. 620x620 (24inx24in) work area.

Using the version just previous to the latest (update came out while I was working on it). 9.19

It’s been working great so far but I took down the machine to redo wiring/solder connections to add longer wires and clean it all up and to put up some new brackets up for my drag chains. I put everything back together and I’m able to home the machine with no problem. I can also use the arrows to move it without issue. But it doesn’t seem to recognize my work area correctly when framing.

For example if I home the machine (which also happens on startup). And then I draw a box out in the work area and attempt to frame it, it doesn’t seem to match up. If I try to do it right after homing, for some reason it moves briefly and kicks the limit switch instead of heading the other direction.

However, if I move position to center manually and then hit frame, it does perform the action correctly although not anywhere near where it’s showing on LB.

My question is two fold:

When I try framing from home position why would it move the opposite way/stop suddenly? (I do have bumper settings for home switches set up, it’s no issue for me to go home and move away from home with arrows manually)

What would cause it to not understand the work area after homing the machine?

I’ve read a few threads with somewhat similar issues but it seemed more common in CNC setups which mine is not. I’m fairly sure I didn’t alter any settings in lightburn when performing the maintenance and I’m not sure if something is wrong with hardware. Wiring seems fine as everything seems to operate correctly until framing.

I’ve also tried homing then selecting get position (which shows as 0,0,0) and then setting that as origin. This had no effect. Problem still occurred.

Any thoughts?

Have tried messing around but can’t seem to get it corrected.
Machine settings are:
























































Any advice is much appreciated.

Whenever I try to frame I get this error: ALARM:2
G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the ‘Devices’ button to reset the connection)
On or near line 2:

Homing works perfectly fine and the manual arrows work perfectly fine.

I have absolute coords selected, no offset for laser, nothing out of the ordinary that I can think of.

After homing, get location shows x=0, y=0

When I go all the way to the opposite corner and get position it shows x= --0.930 and y=0.084 (coordinates should actually be like 23 inches x 23 inches

Really scratching my head on this one.

I made some changes.

Changed $10=0 and $13=0.

This seems to have fixed the area problem where it was only registering .093 as the total space, but my X axis is still negative. I’m probably missing something very simple to flip that positive, but I’m glad there is progress.

Okay I had to reverse the direction pin on the stepper and that kicked it out of the negative space.

So, to sum this up - $10 and $13 needed to be set to 0 (have no idea how I altered those in the first place).

Then inverted direction pin on X axis.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.