Eleksmega laser fires but No Movement (no home, no manual control)

Having an issue that I’m thinking might be something simple I overlooked.

I had last used my machine in spring and tucked it away in the corner of the garage. It worked then.

I took it out the other night and ran into an odd problem where it does not home, does not actually move at all, manual jog controls do nothing for movement on any axis.

However… They do Flash the laser. What I mean by this: if I hit the left, right, up or down buttons on the movement tab, the laser will fire for approximately the amount of time it would take to move the normal steps if it was moving.

Its almost like I wired all the stepper outputs from the controller to go to the laser instead. The position data below reflects that as well. It thinks the head is moving.

Has anyone encountered something like that in the software?

Settings and data from homing and movement attempts are below.

My machine is set up as Grbl

ok
$0=10
$1=25
$2=0
$3=7
$4=0
$5=0
$6=0
$10=1
$11=0.010
$12=0.002
$13=0
$20=0
$21=0
$22=1
$23=3
$24=2500.000
$25=3000.000
$26=250
$27=1.000
$30=1000
$31=0
$32=1
$33=4000.000
$34=0.000
$35=1.000
$36=100.000
$37=0
$100=200.000
$101=200.000
$102=200.000
$103=200.000
$110=3000.000
$111=3000.000
$112=4000.000
$113=4000.000
$120=400.000
$121=400.000
$122=400.000
$123=350.000
$130=550.000
$131=475.000
$132=140.000
$133=609.000
ok
<Idle|MPos:-780.000,10.000,0.000,0.000|FS:0,0|WCO:0.000,0.000,0.000,0.000>
ok
Starting stream
[MSG:Pgm End]
Stream completed in 0:00
Grbl 1.1i [‘$’ for help]
[MSG:‘$H’|‘$X’ to unlock]
error:9
G-code locked out during alarm or jog state.
[MSG:Caution: Unlocked]
ok
[VER:1.1i.20200611:]
[OPT:VMZH,253,254]
Target buffer size found
ok
ALARM:9
Homing fail. Could not find limit switch within search distance. Defined as 1.5 * max_travel on search and 5 * pulloff on locate phases.
ok
Grbl 1.1i [‘$’ for help]
[MSG:‘$H’|‘$X’ to unlock]
[MSG:Caution: Unlocked]
ok
ok
ok
<Idle|MPos:-825.000,0.000,0.000,0.000|FS:0,0|WCO:0.000,0.000,0.000,0.000>
ok
Starting stream
[MSG:Pgm End]
Stream completed in 0:00
<Idle|MPos:-815.000,0.000,0.000,0.000|FS:0,0|WCO:0.000,0.000,0.000,0.000>
ok
Starting stream
[MSG:Pgm End]
Stream completed in 0:00
<Idle|MPos:-805.000,0.000,0.000,0.000|FS:0,0|WCO:0.000,0.000,0.000,0.000>
ok
Starting stream
[MSG:Pgm End]
Stream completed in 0:00
<Idle|MPos:-795.000,0.000,0.000,0.000|FS:0,0|WCO:0.000,0.000,0.000,0.000>
ok
Starting stream
[MSG:Pgm End]
Stream completed in 0:00
<Idle|MPos:-795.000,10.000,0.000,0.000|FS:0,0|WCO:0.000,0.000,0.000,0.000>
ok
Starting stream
[MSG:Pgm End]
Stream completed in 0:00

Check that the power supply is working correctly and providing power to the controller.

Thanks for the reply I have double checked and it is supplying power (I haven’t multimetered it, just going off the lights and fans…

I took a video clip to show what’s going on. To me it seems like lightburn thinks it’s working just fine and so it may be a hardware issue. I wanted to check to see if there could be something up in the software or machine settings though before I get my hands too dirty.

The laser flashing is when I click one of the movement buttons.

Photos of the board and steppers




Don’t take this for granted. Try disconnecting the USB cable and power on the laser. Does the laser turn on?

USB power is sufficient to power the controller but wouldn’t be sufficient to drive the stepper motors.

The blinking of the laser light on move attempt is very strange, however, so not sure what’s going on there.

Oh, yeah, the green light on the Nano comes on with the usb.

The blue lights only power up with the Main power, i have two auxiliary fans that power up only through main power and those are kicking on. I don’t think it’s a power issue, but I do have another power supply around, I may try that just for the hell of it.

It honestly seems like the connections to the steppers got directed to the laser itself and I’m having trouble wrapping my head around the logic there if it isn’t somethin in the software.

The wiring is correct, as it worked fine previously. But perhaps something in the board went wacky… That seems the simplest answer if it isn’t a software setting.

When you say software, are you referring to LightBurn or to a different part of the system? It’s almost certainly not LightBurn in this case.

You may want to try reflashing the firmware in case that’s gone bad.

Is this powered through the controller or through a separate pathway?

What is the rating of the power supply? Are you sure the power supply is rated for the amount of current that’s being demanded? Or that the controller can handle passing that much current?.

This isn’t out of the question. You may want to start taking measurements off of the controller to confirm.

Yes lightburn Software, that’s the main thing I wanted to rule out.

I’m reasonably certain it’s not a wiring issue or a power supply issue. I don’t have it in front of me at the moment but it’s a 12v5amp supply and the extra fans are just tapped into the fan outputs on the eleksmaker board. (2 small 12v 0.16a Fans)

I’ve also shut the fans off (I have them routed through switches) makes no difference.

Power supplies can certainly go bad I suppose but short of that, it should all be adequate. Same setup I used all last winter/spring.

I’m more thinking it could be the board itself. Just the way all movement controls are “rerouting” to go to the laser instead. I am having trouble with the logic of anything else causing that specific problem unless it’s the software/lightburn, which it sounds like it isn’t… Or the controller.

In lightburn, everything is acting as normal in terms of pressing move and lightburn registering the move (though in reality the laser fires for the equivalent time of 2 steps or whatever move distance is set to. )

I do recall about a month ago I had a plastic container I use as a nuts and bolt bowl get knocked over the edge of my bench and it fell right onto the control board, but I have a semi open case/lid on it to protect it so I wasn’t overly concerned… Perhaps the kinetic impact jarred something within the controller… The whole unit/work surface was under a dust cover.

I see Tim has a black and blue 3, so I decided to pick one up and just call it a reason to upgrade.

I actually have another BnB Nano I could probably swap out to test if that was damaged when the container fell. (it took the brunt of force since it’s located topside)

If you have a meter I’d suggest testing the controller for expected voltages.

I found the problem… smh

That little container drop that I mentioned… Definitely unseated the Nano. At the angle of my normal point of view, I didn’t even notice until I actually got to eye level. Was going to swap it out and bingo bango…

Hardware problem after all.

Nice. At least easily remedied once found. Glad you’re back up and running.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.