Enabled homing in machine settings

I enabled the homing function in machine settings and now my laser slowly moves to the far end of the laser bed and won’t respond to anything. I tried to go back to machine settings to disable homing but now it shows nothing and say’s failure to connect. I have a Longer Ray5. Any ideas?

Have you unplugged and re-plugged in the usb cord?

You should see the port in the laser window, you might have to select another port as usb usually just add one to port… usb0, usb1 etc…

What was the reasoning behind enabling homing? I assume it didn’t home when you got it…?


Yes I’ve unplugged the usb. I’ve deleted it and reinstalled. It shows Ready but will not respond to anything and when I go to machine settings it’s blank.
Homing has never worked so I thought I’d enable it.

If the machine is not equipped with limit switches, it cannot home.

If you select the ‘console’ tab in the cut/layers window it should display the startup message from your controller. Indicating it’s connected and talking.

You can’t modify the configuration of the machine without it being connected.

You’ll have to keep trying with the usb until it can communicate. I find some of these use connections quite frustrating.

Cut and past the console output here using the blockquote (double quotes) in the tool bar.


I didn’t know that about limit switches. No I don’t have them.
Waiting for connection…
Waiting for connection…
[MSG:Start mDNS with hostname:http://grblesp.local/]
[MSG:HTTP Started]
[MSG:TELNET Started 8080]
[MSG:‘$H’|‘$X’ to unlock]
Grbl 1.1 [‘$’ for help]
Your Grbl may not support Variable Power mode (M4)
If your laser does not turn off between cuts,
switch to the GRBL-M3 device
[MSG:‘$H’|‘$X’ to unlock]
[MSG:Caution: Unlocked]
[MSG:Using machine:LGT RAY]

Not sure what you mean about blockquote…

Usually you get an error message when it fails to home… it’s not in the output you posted. I would say from the post that it’s working.

Where did you change homing?

After it says ‘ok’ you should be able to enter or change the homing at that point.

It’s connected by your output.

You can enter $20=0 to disable homing… 20 through 22 should be zero.

If it’s connected you can change homing from the console by entering $ commands or via Lightburn Edit → Machine Settings…

Make sense?


I have the same problems, do you found the solution??? i’m trying 2 weeks to resolve the problem, but i can’t.
Maybe you can help me

What error do you get?

You do have switches for the limits?


1 Like


Please if you can watch my video in Youtube!! i made a video with the problem is 2 weeks that my laser is blocked and we can’t resolve the problem and we can’t work !!! is urgent!!

I can’t read any of what’s on the screen, so that doesn’t help. It appears to be already failing from the start of the video as far as I can tell ?

Believe me I understand your frustration. Been there, done that…

You need to relax and answer our questions. We know you know the issue, but we can’t read your mind of what’s occurred that may have caused this.

  1. do you have homing switches
  2. has it worked previously
  3. did you check operation of the limit switch it’s failing to detect.
  4. do you have a multi-meter


The laser was working for two years perfectly for cutting and engraving, but for 2 months, the laser was not cutting perpendicular, for example a square cut in wood, it was not exactly on the right side and on the left side.
So I started to manipulate the machine configurations and all the options in that window were eliminated.
And since then it’s been 3 weeks that the laser is blocked vibrating in the lower corner, making a super loud noise too. And the lightburn does not work at all and says in the machine configuration window (error in communication with the controller)
It is the problem that I misconfigure the software, exactly in machine settings.

I do not know what it is homing switches and this part did you check operation of the limit switch it’s failing to detect is ok.

The problem i think is the window empty of machine settings.

I hope that you can help me because is 3 weeks that i can’t work!!

You have a machine issue, not a Lightburn issue.

Your machine should power up.

You have to turn off homing if you don’t have switches. What usually happens is that it get a fault that it can’t find the home location.

It must be connecting to get the Machine Settings, which it must have as the photo shows the machine settings with the text that it’s read from the controller was successful.

The proper process is to read the Machine settings and save them as a factory default before you modify them… It makes it easy to reset it back to factory settings.

My assumption is that you modified them and lost track of what you modified. You’ll learn how to save things before you modify them as it’s painful if you loose settings.

To fix your machine you’ll have to be able to connect to it via some kind of program, like lightburn and turn off the $20, $21 and $22 variables (post #7)

You might have to unplug the motors to be able to do this without it ramming the corner.

The video is really not that useful. If you move the head to the center then power it up, we can see what it’s trying to do… Your video is ‘after’ the fact and we can’t see what the machine does when it powers up. It should still fault after a short time and quit trying to move the steppers… does it do that?

  1. get connected … there isn’t much you/we can do if it’s a firmware issue and you can’t connect to the device.
  2. will it stop it’s homing operation in a short time with power up
  3. can you see the device on your computers usb port?
  4. if you can, post a video with it off and the head in the center of the work area, then power it up.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.