Engraving on an angle

Hi.
Universal Engraver, GRBL, rotary attachment. I’ve read all previous posts on this but this one seems different. I’ve engraved many times with my rotary attachment with no issues. All of a sudden, its engraving on an angle like this…

thumbnail_image0 (3)

Did I mess up a setting somewhere? Overscanning was off but I turned it on with no change. I read about polarity but don’t understand. Also interesting that I have to flip my image

I’ve used that same rotary and the motor it comes with is too big. it wants >1A to drive it and so if you’re using a little controller like an NEJE or Ortur they only put out ~0.5A so you need to find a smaller motor. Smaller electrically, not physically. NEMA 17 0.5-0.8A should work.

hmmmm, interesting. It’s always worked before. Oh my…Could it be because I have my air conditioner going and robbing power? Worth a shot

nope…that’s not it. Still the same.

Tried it in T2 Laser. Worked fine. Has to be a setting.

what is a T2 laser and are you saying it has the exact same controller, stepper motor driver and power supply as the one showing problems?

No, it’s another program, however…same thing. It seems to happen everytime I flip the image. If I bring in the image and burn…it’s fine but backwards. I then flip it and then I get the angle.

ok but mine was losing steps because of the low current of the controller and high current needs to hold position of the motor. Also didn’t do it all the time and had to do with micro step positions.
I’m out of ideas.

Thanks Doug. Well I guess nobody knows so I downloaded LaserGRBL and it works just fine.

Then it’s likely your acceleration is too high and your workpiece is slipping. I do recall needing to lower a speed setting on Y for the rotary and thinking it should be included in the rotary configuration of LightBurn.

Ok, I finally got it. My rotary was plugged into the X axis. When I tried Y, it moved unevenly. What I didn’t realize is that there are 2 plugs for the Y axis and you have to unplug both and then plug in the rotary.

Now as I said it worked fine in LaserGRBL but that, somehow, works with the X axis.

My rotary came with NO documentation and the video is in chinese. Oh well, working perfect now.

Thanks Doug.

1 Like