Engraving taking to long

I have a Boss 1416 65 watt- speed 100 power 5.5 bitmap interval 0.065 dpi 391 it takes 707. min is that right it seems like a long time for a patch any ideas?

That would depend entirely on the size of the patch, and what unit “speed 100” is. 100 mm/minute is a much slower speed than 100 mm/second. The default is mm/sec, so if you haven’t changed it, you probably have the artwork sized incorrectly.

If you exported a DXF as mm and imported it as inches, for example, this could make it much larger than expected, which would make it take much longer. When you select the art, it will show how large it is on the top toolbar, like this:

image

The art size is correct. I imported a bitmap where can I change to inches and should I?

You misunderstood - I wasn’t suggesting that you change from mm to inches. You said “speed 100”, which could mean anything. Speed is measured as units over time, so in my case it’s in mm per second, shown here:
image

Yours is apparently in mm/minute, shown here:
image

350 mm/min is about 5.8 mm/sec, so that explains why it’s taking so long.

Go to your settings (click the little gears here):
image

And change the speeds to be in mm/sec:
image

Then, after doing that, change your speed value back to 350 mm/sec and that should make the engraving much faster.

oh I see yes thank you so much!!!