Error in main view


Since the update on the main screen, when you select a fill in a svg (I’ve tried several), the fill appears wrong, but if you preview it, it runs well and the job runs correctly. Why is it ?, I attach 2 models and their two preliminary views.

In the window option I have selected to see “Fill / Smooth” as always but in any of the other options it does not work as it used to…

Can you please provide those two files?

It does not let me attach the SVG in the forum, I put it in an external link.

I have downloaded version and the SVG works perfectly, attached also catptura,

attached also catptura

I have tested version 0.9.10 and it works fine too, i.e. this problem is with the new version.

download link is no longer valid. Maybe try google drive?

@Forsito or you could email it to support [at] lightburnsoftware [dot] com
And reference this forum post.

Yes, I attach a link in Google Drive,

What do I have to send an email to that address to report the bug that I comment on in this post?

No need to send anything to that email. This is fine for reporting the bug. It was just an alternative to uploading to GDrive
Looking at it now…


Sorry but my English is not very good and I sometimes use google translator.

I am waiting to see if the same thing happens to you, in a previous version it goes without problem.

@Forsito - I’ve figured out the problem and yes, it does the same thing for me.
The issue is that your designs have paths that are not closed. For the Stitch graphic, that can easily be fixed by selecting it and going to Edit > Close Path
The other graphic is a little more complicated to fix but it is possible.
We changed the way we render filled shapes a little while ago to better indicate if a shape is properly closed or not but the cut builder works a little differently and cares less if the shape is actually closed.
I’m still looking into if there’s a way to improve the rendering and will let you know if we make any changes.

Ajam, but how is it that in an old version it is shown well and in the new one not?

Because we changed how it renders in the new version. The old version didn’t care if the shape was properly closed but the new version does. This is by design as unclosed shapes can cause other issues.

And will this be solved or will there be a patch or will we have to close the forms in the design software? Because then in the preview the form appears correctly and if you execute the work it executes it correctly, only that problem appears on the main screen

Not sure yet - I’m working on seeing if I can update the rendering.
But generally - you should make sure your shapes are closed. The rendering has been this way for nearly a year and this is the first I’ve seen of the issue so likely it’s just a bit of a fluke with those particular designs.

Yes, the strangest thing is that those same designs in a previous version are shown well, but if they have modified that parameter it is normal that it did not appear before. I will be aware of the post to see if there is any solution, otherwise I will be giving a preview to see if the engraving is correct

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.