Everything backwards

I added limit switches to enable homing. Now everything is backwards. I choose a corner for origin it puts program picture in opposite corner and all text are backwards. I need help

Using the search tool found at the top-right of every page here will provide a bunch of posts covering this same issue. :slight_smile: When you first power the machine, and it homes the laser into a corner to zero itself, which corner does it move toward?

The issue you are having is you have the ‘Machine Origin’ set incorrectly in LightBurn. Setting the ‘Machine Origin’ tells LightBurn the correct size of your bed and the location of 0,0 for your setup.

This location is what you will need to set using the 4-circle control on the following screen. Hit the “Spanner/Screwdriver” icon at the center-top of LightBurn to expose the ‘Device Settings’ window, then click the circle that matches the corner where your laser goes when you first turn the system on.

Without “seeing” your screen, my guess is you currently have it set to the opposite, incorrect corner. For GRBL systems, it is most commonly set to the lower-left corner.

1 Like

I have the correct corner chosen but the program picture is in a different corner. I did have this problem until I added limit switches

Not following you here. Objects in LightBurn can be moved around. Please rephrase.

That Origin dot Rick is showing there in the Device Settings is a mirror control - that’s the only thing it does. If your jobs are coming out upside down, move the dot top to bottom or vice versa. If the jobs are flipped horizontally, move the dot from left to right.

Nearly all GCode machines use front-left (bottom left) as the origin position.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.