Figuring out bed coordinates. Laser not working right

I’m new to lightburn and I cannot figure out for the life of me. Why my diode laser isn’t showing the right coordinates in lightburn

Like you are using inch and getting coordinates in mm?
Explain further for us better help you?

No. Everything is in mm. Just set the laser up. I put in my bed dimensions into lightburn. 400mm x 330mm according to the manual. But it seems that lightburn isn’t reading them properly. When I click go to origin it says “Alarm: hard limit -X on or near line 0:

Your machine has Home switches, right? Why are you clicking on this button? Home is always in one place, typically the front-right corner. Origin can be anywhere, good or bad.

Home the machine, use Absolute Coords in the laser window, and leave all the Origin buttons alone for now.

If this does not clear up your issue, come back here for lots more suggestions.

Okay so i redid everything. same bed dimensions. and the home of the laser is the top right corner. i press start and it moves down and stops. and just says “alarm”

Unless your laser frame is mounted vertical, describe the position as if you were looking down on the machine. So you say “Home” is the right-rear corner, but it heads for the front-left corner, correct?

Okay yes. home is right rear corner. i press start and it moves down in a straight line. stops halfway and says alarm

Ok, now for the fun part.

In the Console window, enter these GRBL commands:
$$
$#
?
Then copy and paste the results in your Reply.

Its saying that the $$ command is an invalid statement

$#

[G54:0.0000,0.0000,0.0000]

[G55:0.0000,0.0000,0.0000]

[G56:0.0000,0.0000,0.0000]

[G57:0.0000,0.0000,0.0000]

[G58:0.0000,0.0000,0.0000]

[G59:0.0000,0.0000,0.0000]

[G59.1:0.0000,0.0000,0.0000]

[G59.2:0.0000,0.0000,0.0000]

[G59.3:0.0000,0.0000,0.0000]

[G28:0.0000,0.0000,0.0000]

[G30:0.0000,0.0000,0.0000]

[G92:0.0000,0.0000,0.0000]

[TL0:0.0000]

[PRB:0.0000,0.0000,0.0000:0]

?

ok

<Idle|MPos:0.0000,0.0000,0.0000,0.0000|WPos:0.0000,0.0000,0.0000|F:5400.0,100.0>

Type $ and post the output.

the $ command says, unsupported command.

Ok. And:
config-get sd
cofig-get local

config-get sd

cached: sd is not in config

and the local one is an unsupported command

Could you post your config.txt?

Also an unsupported command

That was a request, not a command to enter.

Thank you @parsec for stepping in. If it is not a GRBL Friendly controller, I am useless.

1 Like

Oh my bad. how do i find the config.txt

Interesting. I can’t tell what type of controller this is (yet).

Entering $i in the Console window (followed by Enter) might generate a system information report and may offer further insight into which controller you have.

We’re finding more and more control board ‘customizations’ on the market where GRBL troubleshooting commands are removed or disabled.

[G0 G54 G17 G21 G90 G94 M0 M5 M9 T0 F5400.0000 S0.8000] This is the $I command