File changes since update

I’ve noticed since the update some of my LB files now open with changes to cut settings. One in particular is how many passes. Some of my many times used files now open with multiple passes. I am not the only one this is happening to… Not a big deal now that i know… but
Thanks for any input

Where are you getting this from? I have not seen this reported previously as far as I can remember.

FB laser group image

There is no universe in which a LightBurn update changed the steps on someone’s 4th axis.

A point of confusion I have seen relatively often, and coded in a warning for, is people using “Import” for LightBurn project files instead of “Open”. “Import” is used to bring vectors from a file into an existing project, without cut settings, where Open is used to open an existing file, including the settings. If you run LightBurn, and use “Import” to bring in a project file, it wouldn’t bring in the cut settings with that file, and would just leave the cut settings as whatever they were from the last thing you worked on.

The only other explanation I can think of is if you pointed the mouse at the pass count and used the scroll wheel accidentally - that could change the number. I’ve tried to find a way to lock those controls so you have to click them first to use the mouse wheel, but haven’t found a way to do that yet.

1 Like

gotta agree on the 4th axis.
I can assure you I “open” LB files vs “import” it also wasn’t all files, just a few. They have all been corrected so cannot repeat.
Must say i do find it odd that “7” was the same number of passes mine changed to.
My issue is no longer an issue, just passing forward that others are experiencing this as well… do with it what you may.
Thanks for the reply

I too have had files open with number of passes set to 7. No rhyme or reason to it that I have been able to tell, it seems totally random.

I’ll have a look - if more than one person has seen the same number pop up, that at least lends weight to it being an error of some sort.

I’ve dug through everything that touches, reads, or writes the numPasses value, and there is nothing out of sorts in there. I’ll poke around the stuff near it - it might be something writing a value into a nearby memory location that’s running out of bounds.

Sean’s Z hopping is because he has Z enabled. Unless he has a specific reason to have it on, he should just turn it off, or at least enable the ‘Optimize Z Moves’ flag to prevent the retract/plunge behavior at the end/start of each cut with a Z offset. It’s bizarre to me that I’ve never heard a peep from him about this - it’s not like he doesn’t know where to find us.

Apologies if I seemed a little prickly about this, but I get blamed for everything. “I installed the latest update and now my laser isn’t found, my wife left me, my coffee maker isn’t working, and my car won’t start. Where do I find the previous version?” :slight_smile:


Yup. I installed the latest version of LB last week and the next morning I had a flat tire on my truck. The only way that a drywall screw could have got in my tire is if there was a loose one in the last update.
And as PROOF that it’s your fault, my neighbor who does NOT use LB did NOT have a flat tire. Coincidence? I think not…

But merry Christmas and a happy new year to you and your family anyway. :slight_smile:


I don’t know how that can be… around here “everything” is my fault. And… no worries, I can only imagine

Interviewer: “For this job we need someone responsible.”
Interviewee: “I’m the one you want! At my last job every time anything went wrong,
They told me that I was responsible.”


Merry Christmas,
i did not have a flat tire, we won’t talk about my wife.
Now if I can get my C3d (older verion) working with Rotary (but no Z axis) Ill be in business.
Happy New Year.

Not sure how it can be your fault, OZ - Clearly it’s mine - Global warming, depletion of the ozone layer, Internet is slow, dog boofed in the living room (uh, that actually was my fault - I know she can’t handle beer)…


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.