File limits with my controller

I’m using a ruida 644xg controller and I’ve found that I can’t upload files larger than 35,000kb. Is there a way to check what the file size is before I send it to my controller. I’m a bit tired of sending the file and finding out it’s bigger than my controller can handle after I’ve already wasted materials.

The files aren’t that big either until I put them in lightburn. Its taking a 366kb PNG file and when I run the file it’s saying it’s 40,000+kb. I don’t get it.

Thanks :+1:

What settings do you have set for that Image Layer? The ‘Line Interval’ or DPI setting can increase the size of output, more lines per inch = larger file size.

I’m running them at 275dpi. I can get a smaller file sizes at 250dpi but I’m not getting the shading I’m desiring at that DPI.

I’m reading that most ruida controllers max out at 100mb. I’m not even close to that and I’m hitting issues. I’ve cleared my board and all the files so there’s nothing taking memory away there.

I found a way to find out file size before you send to controller though. Hit save as RFD and then you can check file size where it saves that file. As long as I’m less than 35,000kb I’m good. It would be nice to not have to worry about that though haha.

How have you tried to get the file to the laser, ‘Send’, ‘Start’? How are you connected to the laser, USB, Ethernet? Have you tried testing with a different software, RDWorks, to see if you observe the same results? That would be worth looking into.

Try clicking the ‘File’ button on the controller itself, select ‘Other+’, then ‘del all mem file’. If that doesn’t work, you can also try ‘format memory’ in that same menu. That might eliminate the 35mb limit - you should be able to go much higher.

Are you running these files as grayscale, by chance? That would make them quite large.

PNG is a compressed file format. LightBurn takes that file, sizes it to the desired output scale, dithers it, then converts the dithered version into commands that the laser accepts to draw it. It will usually be quite a bit larger than the original.


Im connecting using USB. If i send the file straight to the controller from lightburn I don’t know what the file size is until the progress bar shows up. normally by that point the project has started and if it’s too big i have to stop the project and lose material in the process. Saving the RD file first keeps me from having to guess the size. It would be nice if the preview menu had this displayed somewhere but I can’t locate it if it does. If I’m not paying attention it will load the file as far as it can and then my laser starts acting crazy. I usually have to completely reset lightburn and my machine if this happens. It would be nice to decrease the file size some way. As of now I’m having to split my images into sections to do what im needing to do. Theres always a seem in the image doing it this way which bothers me.

I am running these as grayscale images. Taking 3d models in blender and trying to convert them to do 3d relief. I have learned a lot over the last week lol. I just cleared controller memory and im trying to send to controller now. Makes sense about the PNG being compressed didn’t realize it was that extreme. Learning more and more.

sidenote. clearing the memory worked! I thought deleting the files was clearing the memory but apparently not. Thank you so much for the help!

Ruida controllers are funny. And by “funny” I mean… :slight_smile:

Glad that worked!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.